projects
/
openwrt
/
svn-archive
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
61c6b87
)
build a compressed kernel image to use with i386 bootloaders
author
Nicolas Thill
<nico@openwrt.org>
Sat, 13 Aug 2005 07:34:47 +0000
(07:34 +0000)
committer
Nicolas Thill
<nico@openwrt.org>
Sat, 13 Aug 2005 07:34:47 +0000
(07:34 +0000)
SVN-Revision: 1619
openwrt/target/linux/linux-2.4/soekris.mk
patch
|
blob
|
history
diff --git
a/openwrt/target/linux/linux-2.4/soekris.mk
b/openwrt/target/linux/linux-2.4/soekris.mk
index 4fa8fff8cf9baa7b695ee5484d775db534be4713..fdfbbf9b960a34716c5c4263c0a4b74e96a15f15 100644
(file)
--- a/
openwrt/target/linux/linux-2.4/soekris.mk
+++ b/
openwrt/target/linux/linux-2.4/soekris.mk
@@
-9,3
+9,10
@@
$(eval $(call KMOD_template,WD1100,wd1100,\
$(MODULES_DIR)/kernel/drivers/char/wd1100.o \
,CONFIG_WD1100))
+
+$(LINUX_BUILD_DIR)/bzImage: $(LINUX_DIR)/vmlinux
+ $(MAKE) -C $(LINUX_DIR) TOPDIR=$(LINUX_DIR) ARCH=$(LINUX_KARCH) PATH=$(TARGET_PATH) bzImage
+ cp -f $(LINUX_DIR)/arch/i386/boot/bzImage $@
+ touch $@
+
+compile: $(LINUX_BUILD_DIR)/bzImage