Add msdos kernel module (#1029)
authorFlorian Fainelli <florian@openwrt.org>
Sat, 9 Dec 2006 19:46:28 +0000 (19:46 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 9 Dec 2006 19:46:28 +0000 (19:46 +0000)
SVN-Revision: 5740

openwrt/target/linux/Config.in
openwrt/target/linux/control/kmod-msdos.control [new file with mode: 0644]
openwrt/target/linux/linux-2.4/Makefile
openwrt/target/linux/linux-2.4/config/brcm

index 865ec284f4ef092209d8096cc9250ff2162ed824..afb0970cc23c0cf9268140423f25994562bc5c1c 100644 (file)
@@ -363,6 +363,12 @@ config BR2_PACKAGE_KMOD_VFAT
          Kernel modules for VFAT filesystem support
          useful for usb mass storage devices
 
+config BR2_PACKAGE_KMOD_MSDOS 
+        tristate "MSDOS filesystem support" 
+        default m 
+        help 
+          Kernel modules for MSDOS filesystem support 
+
 config BR2_PACKAGE_KMOD_MINIX
        tristate "MINIX filesystem support"
        default m
diff --git a/openwrt/target/linux/control/kmod-msdos.control b/openwrt/target/linux/control/kmod-msdos.control
new file mode 100644 (file)
index 0000000..e01c4b1
--- /dev/null
@@ -0,0 +1,4 @@
+Package: kmod-msdos 
+Priority: optional 
+Section: sys 
+Description: Kernel modules for MSDOS filesystem support 
index 1fffa680958b2bfa83ab766ab344be5c366d748e..b82b2d43ebb50500538345e4bab8fa8b5e4fb328 100644 (file)
@@ -209,6 +209,9 @@ $(eval $(call KMOD_template,VFAT,vfat,\
        $(MODULES_DIR)/kernel/fs/vfat/vfat.o \
        $(MODULES_DIR)/kernel/fs/fat/fat.o \
 ,CONFIG_VFAT_FS,,30,fat vfat))
+$(eval $(call KMOD_template,MSDOS,msdos,\ 
+        $(MODULES_DIR)/kernel/fs/msdos/msdos.o \ 
+,CONFIG_MSDOS_FS,,30,msdos)) 
 $(eval $(call KMOD_template,NLS_CP437,nls-cp437,\
        $(MODULES_DIR)/kernel/fs/nls/nls_cp437.o \
 ,CONFIG_NLS_CODEPAGE_437,,40,nls_cp437.o))
index f2feb79520d389bf3576dc397571a9e083536c30..e5c9bb28d9dc9cc7c53fa57d094cc87241be3f31 100644 (file)
@@ -1027,7 +1027,7 @@ CONFIG_EXT3_FS=m
 CONFIG_JBD=m
 # CONFIG_JBD_DEBUG is not set
 CONFIG_FAT_FS=m
-# CONFIG_MSDOS_FS is not set
+CONFIG_MSDOS_FS=m
 # CONFIG_UMSDOS_FS is not set
 CONFIG_VFAT_FS=m
 # CONFIG_EFS_FS is not set