ath79: add support for TP-Link CPE710-v2
authorTim Noack <tim@noack.id>
Mon, 21 Oct 2024 12:21:59 +0000 (12:21 +0000)
committerPetr Štetiar <ynezz@true.cz>
Thu, 28 Nov 2024 18:49:03 +0000 (18:49 +0000)
TP-Link CPE710-v2 is an outdoor wireless CPE for 5 GHz with one Ethernet
port based on the AP152 reference board. Compared to the CPE710-v1, the
only change observed in hardware is that the mdio address of the ethernet
physical changed from 0x4 to 0x0.

Specifications:
- SoC: QCA9563-AL3A MIPS 74kc @ 775MHz, AHB @ 258MHz
- RAM: 128MiB DDR2 @ 650MHz
- Flash: 16MiB SPI NOR Based on the GD25Q128
- Wi-Fi 5Ghz: ath10k chip (802.11ac for up to 867Mbps on 5GHz wireless
  data rate), based on the QCA9896
- Ethernet: one 1GbE port
- 23dBi high-gain directional 2×2 MIMO parabolic antenna
- Power, LAN, WLAN5G Blue LEDs

Flashing instructions:
Flash factory image through stock firmware WEB UI or through TFTP
To get to TFTP recovery just hold reset button while powering on for around
30-40 seconds and release.
Rename factory image to recovery.bin
Stock TFTP server IP:192.168.0.100
Stock device TFTP address:192.168.0.254

Signed-off-by: Tim Noack <tim@noack.id>
Link: https://github.com/openwrt/openwrt/pull/16637
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
(cherry picked from commit 5572e0196a93604716ec36ebb8db6737fc6677aa)
Link: https://github.com/openwrt/openwrt/pull/17097
Signed-off-by: Petr Štetiar <ynezz@true.cz>
target/linux/ath79/dts/qca9563_tplink_cpe710-v2.dts [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/01_leds
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/image/generic-tp-link.mk

diff --git a/target/linux/ath79/dts/qca9563_tplink_cpe710-v2.dts b/target/linux/ath79/dts/qca9563_tplink_cpe710-v2.dts
new file mode 100644 (file)
index 0000000..fe277fc
--- /dev/null
@@ -0,0 +1,20 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9563_tplink_cpe710.dtsi"
+
+/ {
+       model = "TP-Link CPE710 v2";
+       compatible = "tplink,cpe710-v2", "qca,qca9563";
+};
+
+&mdio0 {
+       phy0: ethernet-phy@0 {
+               reg = <0>;
+               reset-gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+       };
+};
+
+&eth0 {
+       phy-handle = <&phy0>;
+       phy-mode = "sgmii";
+};
index 0e5731dd743186f2ad11b3d8c70db10ec25a3ce2..6409adb78ad825be4351b621693d662ed101316e 100644 (file)
@@ -222,7 +222,8 @@ openmesh,mr900-v1|\
 openmesh,mr900-v2|\
 openmesh,mr1750-v1|\
 openmesh,mr1750-v2|\
-tplink,cpe710-v1)
+tplink,cpe710-v1|\
+tplink,cpe710-v2)
        ucidef_set_led_netdev "lan" "LAN" "blue:lan" "eth0"
        ;;
 compex,wpj344-16m|\
index 8f79a3fad8114dbc884e8deded4e54539e52dd57..2bd97442d956dc8d47e98a37e3ec019a653bb531 100644 (file)
@@ -89,6 +89,7 @@ ath79_setup_interfaces()
        tplink,cpe610-v1|\
        tplink,cpe610-v2|\
        tplink,cpe710-v1|\
+       tplink,cpe710-v2|\
        tplink,eap225-outdoor-v1|\
        tplink,eap225-outdoor-v3|\
        tplink,eap225-v1|\
index 643de76f7c2ba79781ae9b68e9d5c241bca8cb8f..c42338db78320367c5864013b31c61e4952e6e74 100644 (file)
@@ -391,6 +391,17 @@ define Device/tplink_cpe710-v1
 endef
 TARGET_DEVICES += tplink_cpe710-v1
 
+define Device/tplink_cpe710-v2
+  $(Device/tplink-safeloader-uimage)
+  SOC := qca9563
+  IMAGE_SIZE := 15680k
+  DEVICE_MODEL := CPE710
+  DEVICE_VARIANT := v2
+  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9888-ct
+  TPLINK_BOARD_ID := CPE710V2
+endef
+TARGET_DEVICES += tplink_cpe710-v2
+
 define Device/tplink-eap2x5
   $(Device/tplink-safeloader)
   LOADER_TYPE := elf