ath79: D-Link DIR-825 B1 add factory.bin recipe
authorWill Moss <willormos@gmail.com>
Thu, 10 Nov 2022 19:55:11 +0000 (19:55 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 27 Nov 2022 14:43:08 +0000 (15:43 +0100)
- Bring back factory.bin image which was missing after porting device to ath79 target
- Use default sysupgrade.bin image recipe
- Adjust max image size according to new firmware partition size after
"ath79: expand rootfs for DIR-825-B1 with unused space (aca8bb5)" changes
- Remove support of upgrading from version 19.07, because partition size changes mentioned above

Signed-off-by: Will Moss <willormos@gmail.com>
(cherry picked from commit a58146d452c50387256d4a616c055ddf3248496f)

target/linux/ath79/image/generic.mk

index d088f91019f1f62eb579a50297ba070d4a75759b..31d296fb62a1bb3fee4dfaba894f8339c48dd59c 100644 (file)
@@ -969,12 +969,14 @@ define Device/dlink_dir-825-b1
   DEVICE_VENDOR := D-Link
   DEVICE_MODEL := DIR-825
   DEVICE_VARIANT := B1
-  IMAGE_SIZE := 6208k
-  IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
-       check-size | append-metadata
   DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport \
        kmod-leds-reset kmod-owl-loader
-  SUPPORTED_DEVICES += dir-825-b1
+  IMAGE_SIZE := 7808k
+  FACTORY_SIZE := 6144k
+  IMAGES += factory.bin
+  IMAGE/factory.bin = append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | \
+       pad-rootfs | check-size $$$$(FACTORY_SIZE) | pad-to $$$$(FACTORY_SIZE) | \
+       append-string 01AP94-AR7161-RT-080619-00
 endef
 TARGET_DEVICES += dlink_dir-825-b1