ltq-adsl-app: add dsl_cpe_pipe.sh script
authorJan Hoffmann <jan@3e8.eu>
Sat, 19 Oct 2024 17:38:24 +0000 (19:38 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 20 Oct 2024 23:04:05 +0000 (01:04 +0200)
This allows to obtain detailed diagnostic information about the DSL
connection from the modem. The script is copied from the corresponding
packages for VDSL modems.

Signed-off-by: Jan Hoffmann <jan@3e8.eu>
Link: https://patchwork.ozlabs.org/project/openwrt/patch/20241019174041.1281093-4-jan@3e8.eu/
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/network/config/ltq-adsl-app/Makefile
package/network/config/ltq-adsl-app/files/dsl_cpe_pipe.sh [new file with mode: 0755]

index 94e2e9d0d77de4a30205fa7a4345b5c9ffe76d1a..b96a3f71e5bd1c3c2e7f6a9a2b54fe433963097c 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=dsl_cpe_control_danube
 PKG_VERSION:=3.24.4.4
-PKG_RELEASE:=12
+PKG_RELEASE:=13
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_BUILD_DIR:=$(BUILD_DIR)/dsl_cpe_control-$(PKG_VERSION)
 PKG_SOURCE_URL:=@OPENWRT
@@ -77,6 +77,7 @@ define Package/ltq-adsl-app/install
        $(INSTALL_BIN) ./files/10_atm.sh $(1)/etc/hotplug.d/dsl
        $(INSTALL_BIN) ./files/10_ptm.sh $(1)/etc/hotplug.d/dsl
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dsl_cpe_control $(1)/sbin
+       $(INSTALL_BIN) ./files/dsl_cpe_pipe.sh $(1)/sbin/
 endef
 
 $(eval $(call BuildPackage,ltq-adsl-app))
diff --git a/package/network/config/ltq-adsl-app/files/dsl_cpe_pipe.sh b/package/network/config/ltq-adsl-app/files/dsl_cpe_pipe.sh
new file mode 100755 (executable)
index 0000000..9002b7b
--- /dev/null
@@ -0,0 +1,18 @@
+#!/bin/sh
+
+pipe_no=0
+
+# use specified pipe no
+case "$1" in
+0|1|2)
+pipe_no=$1; shift; ;;
+esac
+
+
+#echo "Call dsl_pipe with $*"
+lock /var/lock/dsl_pipe
+echo $* > /tmp/pipe/dsl_cpe${pipe_no}_cmd
+result=$(cat /tmp/pipe/dsl_cpe${pipe_no}_ack)
+lock -u /var/lock/dsl_pipe
+
+echo "$result"