build: add support for host building in a subdirectory
authorMichael Pratt <mcpratt@pm.me>
Thu, 11 Jul 2024 06:36:18 +0000 (02:36 -0400)
committerRobert Marko <robimarko@gmail.com>
Sat, 27 Jul 2024 18:32:20 +0000 (20:32 +0200)
Add HOST_MAKE_PATH and use it in order to execute Make
in a subdirectory of the build directory
and in a similar way that MAKE_PATH is used for target building.

Signed-off-by: Michael Pratt <mcpratt@pm.me>
Link: https://github.com/openwrt/openwrt/pull/15991
Signed-off-by: Robert Marko <robimarko@gmail.com>
include/host-build.mk

index 8313dbfbb39e73088b24402629d5156ed1f11fe1..4dfa055db903d035b39af71312c4f58fd5380d4a 100644 (file)
@@ -111,9 +111,11 @@ define Host/Configure
   $(call Host/Configure/Default)
 endef
 
+HOST_MAKE_PATH ?= .
+
 define Host/Compile/Default
        +$(HOST_MAKE_VARS) \
-       $(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) \
+       $(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR)/$(HOST_MAKE_PATH) \
                $(HOST_MAKE_FLAGS) \
                $(1)
 endef