update strace to 4.5.19 (#6280)
authorFlorian Fainelli <florian@openwrt.org>
Sat, 5 Dec 2009 01:06:58 +0000 (01:06 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 5 Dec 2009 01:06:58 +0000 (01:06 +0000)
SVN-Revision: 18654

utils/strace/Makefile
utils/strace/patches/100-eabi.patch [deleted file]

index 2019acdc1fe9f79215ca058c98f058aae12ddeae..031b60f05ef59ad1094d92300fa0e37124e11422 100644 (file)
@@ -8,16 +8,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=strace
-PKG_RELEASE:=2
+PKG_RELEASE:=1
 
-OLD_KERNEL=$(findstring y,$(foreach v,23 24 25 26,$(CONFIG_LINUX_2_6_$(v))))
-ifneq ($(OLD_KERNEL),)
+ifeq ($(CONFIG_LINUX_2_6_25),y) 
   PKG_VERSION:=4.5.16
   PKG_MD5SUM:=77f66d09aa82981bb6d65fa19a2c1ba9
   PATCH_DIR:=patches-4.5.16
 else
-  PKG_VERSION:=4.5.18
-  PKG_MD5SUM:=e9449fcee97e6a8ed73934c883c870e0
+  PKG_VERSION:=4.5.19
+  PKG_MD5SUM:=2415e435d61e40315a298c80aced0cda
 endif
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
diff --git a/utils/strace/patches/100-eabi.patch b/utils/strace/patches/100-eabi.patch
deleted file mode 100644 (file)
index 018022a..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
---- a/linux/arm/syscallent.h
-+++ b/linux/arm/syscallent.h
-@@ -431,7 +431,7 @@
-       { 5,    0,      printargs,              "SYS_398"       }, /* 398 */
-       { 5,    0,      printargs,              "SYS_399"       }, /* 399 */
--#if SYS_socket_subcall != 400
-+#if defined(SYS_socket_subcall) && (SYS_socket_subcall != 400)
-  #error fix me
- #endif
-       { 8,    0,      printargs,              "socket_subcall"}, /* 400 */
-@@ -453,7 +453,7 @@
-       { 5,    TN,     sys_sendmsg,            "sendmsg"       }, /* 416 */
-       { 5,    TN,     sys_recvmsg,            "recvmsg"       }, /* 417 */
--#if SYS_ipc_subcall != 418
-+#if defined(SYS_ipc_subcall) && (SYS_ipc_subcall != 418)
-  #error fix me
- #endif
-       { 4,    0,      printargs,              "ipc_subcall"   }, /* 418 */
---- a/system.c
-+++ b/system.c
-@@ -70,10 +70,6 @@
- #include <linux/capability.h>
- #endif
--#ifdef SYS_cacheflush
--#include <asm/cachectl.h>
--#endif
--
- #ifdef HAVE_LINUX_USTNAME_H
- #include <linux/utsname.h>
- #endif