projects
/
openwrt
/
staging
/
nbd.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
5af24a0
)
allow people to add files to the rootfs by putting them in $(TOPDIR)/files/
author
Felix Fietkau
<nbd@openwrt.org>
Fri, 1 Dec 2006 14:01:31 +0000
(14:01 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Fri, 1 Dec 2006 14:01:31 +0000
(14:01 +0000)
SVN-Revision: 5685
package/Makefile
patch
|
blob
|
history
diff --git
a/package/Makefile
b/package/Makefile
index e0483deb59e7414cdff5e9e495718ac5e4187c41..34eba4e3b1e75fdded00d13766f4607ad061756f 100644
(file)
--- a/
package/Makefile
+++ b/
package/Makefile
@@
-55,6
+55,9
@@
install-targets: base-files-install $(INSTALL_PACKAGES)
install:
rm -rf $(BUILD_DIR)/root
$(MAKE) install-targets
+ @if [ -d $(TOPDIR)/files ]; then \
+ $(CP) $(TOPDIR)/files/. $(BUILD_DIR)/root; \
+ fi
@( \
cd $(BUILD_DIR)/root; \
for script in ./etc/init.d/*; do \