compat-drivers: force using include/drm for header namespace
authorLuis R. Rodriguez <mcgrof@do-not-panic.com>
Thu, 27 Sep 2012 23:41:09 +0000 (16:41 -0700)
committerLuis R. Rodriguez <mcgrof@do-not-panic.com>
Thu, 27 Sep 2012 23:43:35 +0000 (16:43 -0700)
Turns out DRM drivers use this:

 #include "drmP.h"

Instead of:

 #include <drm/drmP.h>

Withtout this change we are using the older kernel's header
file and not the one we are cherry pickng over from the kernel
we want to help backport.

Signed-off-by: Luis R. Rodriguez <mcgrof@do-not-panic.com>
Makefile

index d8c7d273b8e7b674e734dc32d8a4e4532924c07c..e3c3fa6d859ff16a66e7e8b51c662aaaf40308c7 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -33,6 +33,7 @@ include $(COMPAT_CONFIG_CW)
 
 NOSTDINC_FLAGS := \
        -I$(M)/include/ \
+       -I$(M)/include/drm \
        -include $(M)/include/linux/compat-2.6.h \
        $(CFLAGS)