Add "pwrtray" application package
authorMichael Büsch <mb@bu3sch.de>
Fri, 20 Aug 2010 14:10:41 +0000 (14:10 +0000)
committerMichael Büsch <mb@bu3sch.de>
Fri, 20 Aug 2010 14:10:41 +0000 (14:10 +0000)
SVN-Revision: 22735

Xorg/app/pwrtray/Makefile [new file with mode: 0644]

diff --git a/Xorg/app/pwrtray/Makefile b/Xorg/app/pwrtray/Makefile
new file mode 100644 (file)
index 0000000..9312cea
--- /dev/null
@@ -0,0 +1,58 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=pwrtray
+PKG_REV:=30e0767cd45fe63f06055488407388dc8446b763
+PKG_VERSION:=$(PKG_REV)
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=git://git.bu3sch.de/pwrtray.git
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_INSTALL:=1
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/pwrtray
+  SECTION:=xorg-app
+  CATEGORY:=Xorg
+  SUBMENU:=app
+  TITLE:=pwrtray
+  URL:=http://bu3sch.de/gitweb?p=pwrtray.git;a=summary
+  DEPENDS:=+qt4
+endef
+
+define Package/pwrtray/description
+  Tiny power control tray application.
+endef
+
+EXTRA_CFLAGS:= \
+       -I$(PKG_BUILD_DIR)/moc
+
+EXTRA_LDFLAGS:= \
+       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
+       -Wl,-rpath=/usr/lib/
+
+MAKE_VARS+= \
+       MOC="$(STAGING_DIR_HOST)/bin/moc" \
+       STRIP="$(STRIP)"
+
+#MAKE_FLAGS+= \
+#      V=1
+
+define Package/pwrtray/install
+       $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/share
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/pwrtray $(1)/usr/bin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/share/pwrtray $(1)/usr/share/
+endef
+
+$(eval $(call BuildPackage,pwrtray))