projects
/
openwrt
/
svn-archive
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
6e71f27
)
build package index in sdk (fixes #51)
author
Felix Fietkau
<nbd@openwrt.org>
Mon, 12 Dec 2005 00:07:56 +0000
(
00:07
+0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Mon, 12 Dec 2005 00:07:56 +0000
(
00:07
+0000)
SVN-Revision: 2628
openwrt/package/sdk/files/Makefile.sdk
patch
|
blob
|
history
diff --git
a/openwrt/package/sdk/files/Makefile.sdk
b/openwrt/package/sdk/files/Makefile.sdk
index b4a3010be482d466317fa282349882636a64d654..6d5f61ad1118bce69c005504348e56e982f3db50 100644
(file)
--- a/
openwrt/package/sdk/files/Makefile.sdk
+++ b/
openwrt/package/sdk/files/Makefile.sdk
@@
-12,7
+12,7
@@
PACKAGES_PREPARE:=$(foreach package,$(PACKAGES),$(package)-prepare)
PACKAGES_COMPILE:=$(foreach package,$(PACKAGES),$(package)-compile)
PACKAGES_CLEAN:=$(foreach package,$(PACKAGES),$(package)-clean)
-all: compile
+all: compile
package_index
compile: $(PACKAGES_COMPILE)
clean: $(PACKAGES_CLEAN)
rm -rf $(BUILD_DIR)
@@
-34,3
+34,9
@@
distclean: clean
$(BUILD_DIR):
mkdir -p $@
mkdir -p $(DL_DIR)
+
+package_index:
+ (cd $(PACKAGE_DIR); \
+ $(STAGING_DIR)/usr/bin/ipkg-make-index . > Packages \
+ )
+