projects
/
openwrt
/
svn-archive
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
310c610
)
Prior to kernel 2.6.23, architecture path was i386, allow that when switching kernel...
author
Florian Fainelli
<florian@openwrt.org>
Sat, 28 Jun 2008 11:08:01 +0000
(11:08 +0000)
committer
Florian Fainelli
<florian@openwrt.org>
Sat, 28 Jun 2008 11:08:01 +0000
(11:08 +0000)
SVN-Revision: 11594
target/linux/rdc/image/Makefile
patch
|
blob
|
history
diff --git
a/target/linux/rdc/image/Makefile
b/target/linux/rdc/image/Makefile
index 4da96b7e18474f5c1940d15fb90246cc55a89734..a8ad0996683253eb12eaeeed00c5f8cc9b636868 100644
(file)
--- a/
target/linux/rdc/image/Makefile
+++ b/
target/linux/rdc/image/Makefile
@@
-7,8
+7,14
@@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
+ifeq ($(CONFIG_LINUX_2_6_23),y)
+ARCH_PATH=i386
+else
+ARCH_PATH=x86
+endif
+
define Image/Prepare
- $(CP) $(LINUX_DIR)/arch/
x86
/boot/bzImage $(KDIR)/bzImage
+ $(CP) $(LINUX_DIR)/arch/
$(ARCH_PATH)
/boot/bzImage $(KDIR)/bzImage
endef
define trxalign/jffs2-128k