projects
/
openwrt
/
staging
/
stintel.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
7b911a9
)
kernel: kmod-crypto-user: Add missing dependency
author
Hauke Mehrtens
<hauke@hauke-m.de>
Wed, 13 Mar 2024 17:09:22 +0000
(18:09 +0100)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Thu, 14 Mar 2024 19:53:34 +0000
(20:53 +0100)
The algif_rng.ko kernel module depends on the rng.ko kernel module with
kernel 6.6 when compiling for MIPS malta.
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/linux/modules/crypto.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/crypto.mk
b/package/kernel/linux/modules/crypto.mk
index 49882c58df4bbc3304c12b6474c7bc1e84e1cea7..ea2a104335bebc25dacbd077d0944fcc8497bfb9 100644
(file)
--- a/
package/kernel/linux/modules/crypto.mk
+++ b/
package/kernel/linux/modules/crypto.mk
@@
-1119,7
+1119,7
@@
$(eval $(call KernelPackage,crypto-test))
define KernelPackage/crypto-user
TITLE:=CryptoAPI userspace interface
- DEPENDS:=+kmod-crypto-hash +kmod-crypto-manager
+ DEPENDS:=+kmod-crypto-hash +kmod-crypto-manager
+LINUX_6_6:kmod-crypto-rng
KCONFIG:= \
CONFIG_CRYPTO_USER \
CONFIG_CRYPTO_USER_API \