projects
/
openwrt
/
staging
/
jow.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
3ee29a8
)
Add a requireheader for squid, should fix it (#2205)
author
Florian Fainelli
<florian@openwrt.org>
Sun, 12 Aug 2007 11:53:23 +0000
(11:53 +0000)
committer
Florian Fainelli
<florian@openwrt.org>
Sun, 12 Aug 2007 11:53:23 +0000
(11:53 +0000)
SVN-Revision: 8404
include/prereq.mk
patch
|
blob
|
history
diff --git
a/include/prereq.mk
b/include/prereq.mk
index 660f67cb1bb9349ef127bb7034aefbb5df1a8f9c..8e5490ccff80161233cc76bede40f16f0e22d696 100644
(file)
--- a/
include/prereq.mk
+++ b/
include/prereq.mk
@@
-47,4
+47,12
@@
define RequireCommand
$$(eval $$(call Require,$(1),$(2)))
endef
+define RequireHeader
+ define Require/$(1)
+ [ -e "$(1)" ]
+ endef
+
+ $$(eval $$(call Require,$(1),$(2)))
+endef
+
.NOTPARALLEL: