gemini: Use absolute paths for tools
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 5 Oct 2024 13:05:50 +0000 (15:05 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 6 Oct 2024 01:46:45 +0000 (03:46 +0200)
Use the absolute path to access the e2fsprogs applications. It is also
working with relative paths, but this makes sure that we use our
versions.

Link: https://github.com/openwrt/openwrt/pull/16607
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/gemini/image/Makefile

index 3ddb6e5554adafb4a35586357164f70fe51b0900..819291ef7fc2fc10f851788b76e6779814aece7b 100644 (file)
@@ -55,8 +55,8 @@ define Build/dns313-images
                --root $@.tmp $@.tmp-boot
 
        # The device firmware needs revision 1 of EXT2
-       tune2fs -O filetype $@.tmp-boot
-       e2fsck -pDf $@.tmp-boot > /dev/null
+       $(STAGING_DIR_HOST)/bin/tune2fs -O filetype $@.tmp-boot
+       $(STAGING_DIR_HOST)/bin/e2fsck -pDf $@.tmp-boot > /dev/null
 
        ./dns313_gen_hdd_img.sh $@ $@.tmp-boot $(IMAGE_ROOTFS) \
                $(CONFIG_TARGET_KERNEL_PARTSIZE) \