projects
/
openwrt
/
staging
/
adrian.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
d867864
)
adds wrapper for uapi directory
author
John Crispin
<john@openwrt.org>
Sat, 15 Dec 2012 01:59:14 +0000
(
01:59
+0000)
committer
John Crispin
<john@openwrt.org>
Sat, 15 Dec 2012 01:59:14 +0000
(
01:59
+0000)
SVN-Revision: 34683
include/kernel.mk
patch
|
blob
|
history
diff --git
a/include/kernel.mk
b/include/kernel.mk
index 589db024db64ca2bf182c05d190c9f6f83d58691..eabf9484fa17484b187107084869ce73f6dde3d2 100644
(file)
--- a/
include/kernel.mk
+++ b/
include/kernel.mk
@@
-35,6
+35,7
@@
else
endif
KERNEL_BUILD_DIR ?= $(BUILD_DIR)/linux-$(BOARD)$(if $(SUBTARGET),_$(SUBTARGET))
LINUX_DIR ?= $(KERNEL_BUILD_DIR)/linux-$(LINUX_VERSION)
+ LINUX_UAPI_DIR=$(firstword $(wildcard $(LINUX_DIR)/include/uapi $(LINUX_DIR)/include))
LINUX_VERMAGIC:=$(strip $(shell cat $(LINUX_DIR)/.vermagic 2>/dev/null))
LINUX_VERMAGIC:=$(if $(LINUX_VERMAGIC),$(LINUX_VERMAGIC),unknown)