build: don't include kernel/libc in package index
authorPaul Spooren <mail@aparcar.org>
Tue, 29 Oct 2024 10:09:24 +0000 (11:09 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Wed, 30 Oct 2024 13:17:33 +0000 (14:17 +0100)
The same that is done in `ipkg-make-index.sh` should happen with APK.
If the pseudo packages, only added to add dependency constraints, are
added to the index, APK happily "upgrades" them and installs updated
kmods, too. However, the Kernel itself is never installed via a regular
package.

Fixes: https://github.com/openwrt/openwrt/issues/16808
Signed-off-by: Paul Spooren <mail@aparcar.org>
package/Makefile

index 9ae94e9a4eb696681a59f704f107b5f0c915e7a4..abe76a619fac4a2b26ca4608c8bb2b297a6e2fd6 100644 (file)
@@ -130,7 +130,7 @@ ifneq ($(CONFIG_USE_APK),)
                        --keys-dir $(TOPDIR) \
                        --sign $(BUILD_KEY_APK_SEC) \
                        --output packages.adb \
-                       *.apk; \
+                       $$(ls *.apk | grep -v 'kernel\|libc'); \
        done
 else
        @for d in $(PACKAGE_SUBDIRS); do ( \