projects
/
openwrt
/
staging
/
rmilecki.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
0e4c9de
)
hostapd: use -ffunction-sections, -fdata-sections and --gc-sections, reduces binary...
author
Felix Fietkau
<nbd@openwrt.org>
Wed, 2 Mar 2011 12:01:08 +0000
(12:01 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Wed, 2 Mar 2011 12:01:08 +0000
(12:01 +0000)
SVN-Revision: 25821
package/hostapd/Makefile
patch
|
blob
|
history
diff --git
a/package/hostapd/Makefile
b/package/hostapd/Makefile
index 3b4978fc8696ee05d2e9a9f366f8defb6d06f270..83622b41babaad83780d721b75365ddc7faeb4f2 100644
(file)
--- a/
package/hostapd/Makefile
+++ b/
package/hostapd/Makefile
@@
-225,6
+225,9
@@
TARGET_CPPFLAGS := \
-DCONFIG_LIBNL20 \
-D_GNU_SOURCE
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+TARGET_LDFLAGS += -Wl,--gc-sections
+
ifdef CONFIG_PACKAGE_kmod-mac80211
TARGET_LDFLAGS += -lm -lnl-tiny
endif