projects
/
openwrt
/
staging
/
wigyori.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
cc04f05
)
final fix for the profile selection
author
Felix Fietkau
<nbd@openwrt.org>
Fri, 2 Mar 2007 23:36:59 +0000
(23:36 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Fri, 2 Mar 2007 23:36:59 +0000
(23:36 +0000)
SVN-Revision: 6474
include/target.mk
patch
|
blob
|
history
diff --git
a/include/target.mk
b/include/target.mk
index d0f7b9bc2b597c395caa95e1fcc237c90ffb96e2..1718a869c14780853bc61c69f9d66cf4769d87b7 100644
(file)
--- a/
include/target.mk
+++ b/
include/target.mk
@@
-5,14
+5,16
@@
# See /LICENSE for more information.
#
-include $(TMP_DIR)/.target.mk
define AddProfile
- ifeq ($(CONFIG_LINUX_$(call confname,$(KERNEL)_$(1))),y)
- PROFILE=$(1)
+ ifeq ($(CONFIG_LINUX_$(1)),y)
+ $(call Profile/$(1))
+ PROFILE=$$(ID)
endif
endef
+include $(TMP_DIR)/.target.mk
+
ifeq ($(IB),1)
$(TMP_DIR)/.target.mk: $(TOPDIR)/.target.mk
$(CP) $< $@