projects
/
openwrt
/
staging
/
lynxis.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
a70800a
)
lzo: disable unaligned access for everything except x86
author
Felix Fietkau
<nbd@openwrt.org>
Sun, 23 Nov 2014 20:10:02 +0000
(20:10 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sun, 23 Nov 2014 20:10:02 +0000
(20:10 +0000)
Fixes issues on ARM
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 43349
package/libs/lzo/Makefile
patch
|
blob
|
history
diff --git
a/package/libs/lzo/Makefile
b/package/libs/lzo/Makefile
index b2bab05f3ed423a684fb148ddb5bdce391c8590a..6a88a6f384c61f958938fa5ec6d8f7d114e0d2be 100644
(file)
--- a/
package/libs/lzo/Makefile
+++ b/
package/libs/lzo/Makefile
@@
-45,6
+45,10
@@
endef
TARGET_CFLAGS += $(FPIC)
MAKE_FLAGS += CFLAGS_O="$(TARGET_CFLAGS)"
+ifeq ($(CONFIG_i386)$(CONFIG_x86_64),)
+ TARGET_CFLAGS += -DLZO_CFG_NO_UNALIGNED=1
+endif
+
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/include/lzo $(1)/usr/include/