projects
/
openwrt
/
staging
/
dangole.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
62cd76a
)
include: also check CONFIG_GPIOLIB for GPIO_SUPPORT
author
Jonas Gorski
<jogo@openwrt.org>
Thu, 4 Jul 2013 13:41:50 +0000
(13:41 +0000)
committer
Jonas Gorski
<jogo@openwrt.org>
Thu, 4 Jul 2013 13:41:50 +0000
(13:41 +0000)
Recent kernels removed GENERIC_GPIO and require GPIO capable
targets to select GPIOLIB instead, so check for both symbols.
Fixed #13814.
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 37166
include/target.mk
patch
|
blob
|
history
diff --git
a/include/target.mk
b/include/target.mk
index 7a704e2206a053594b69cab78a2e8ad913ba3dfa..eeabb25f37812d2da9a7a900b0772cc18aea9784 100644
(file)
--- a/
include/target.mk
+++ b/
include/target.mk
@@
-163,7
+163,7
@@
ifeq ($(DUMP),1)
.SILENT: $(TMP_CONFIG)
.PRECIOUS: $(TMP_CONFIG)
- ifneq ($(CONFIG_GENERIC_GPIO),)
+ ifneq ($(CONFIG_GENERIC_GPIO)
$(CONFIG_GPIOLIB)
,)
FEATURES += gpio
endif
ifneq ($(CONFIG_PCI),)