lua5.3: fix typo calling lua53 instead of lua5.3 for Package Default
authorChristian Marangi <ansuelsmth@gmail.com>
Sun, 10 Dec 2023 10:43:45 +0000 (11:43 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Sun, 10 Dec 2023 10:48:11 +0000 (11:48 +0100)
Fix typo calling lua53 instead of lua5.3 for Package Default definition.

This cause only missing description of the package and doesn't cause
any build regression.

Fixes: c52ca08d4008 ("lua5.3: build shared library")
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
(cherry picked from commit 25e215c14ee6c9f3d54cd1da46a48d9ffe6b254e)
[ fix conflict with changed URL value ]

package/utils/lua5.3/Makefile

index fb664e667329c8f7c23ea5958cd38d1333c477a2..a77ad0e85f9546473afb50b087f5bf3d3024af14 100644 (file)
@@ -30,7 +30,7 @@ define Package/lua5.3/Default
   SUBMENU:=Lua
   SECTION:=lang
   CATEGORY:=Languages
-  TITLE:=Lua programming language
+  TITLE:=Lua programming language (version 5.3)
   URL:=http://www.lua.org/
   MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
 endef
@@ -42,7 +42,7 @@ define Package/lua5.3/Default/description
 endef
 
 define Package/liblua5.3
-$(call Package/lua53/Default)
+$(call Package/lua5.3/Default)
   SUBMENU:=
   SECTION:=libs
   CATEGORY:=Libraries
@@ -51,7 +51,7 @@ $(call Package/lua53/Default)
 endef
 
 define Package/liblua5.3/description
-$(call Package/lua53/Default/description)
+$(call Package/lua5.3/Default/description)
  This package contains the Lua shared libraries, needed by other programs.
 endef