projects
/
openwrt
/
staging
/
blogic.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
165533c
)
MIPS: Set compiler options only after the compiler prefix has ben set.
author
Ralf Baechle
<ralf@linux-mips.org>
Tue, 28 Apr 2009 17:38:35 +0000
(19:38 +0200)
committer
Ralf Baechle
<ralf@linux-mips.org>
Thu, 14 May 2009 12:50:28 +0000
(13:50 +0100)
Otherwise indigestable options might be passed to the host compiler.
Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
arch/mips/Makefile
patch
|
blob
|
history
diff --git
a/arch/mips/Makefile
b/arch/mips/Makefile
index 8d544c7c9fe9435d11d831b8fcae6ee219f2aad3..3d5626ee0a5c91d0adb3a2d2b0ef22c6ee3c2b6f 100644
(file)
--- a/
arch/mips/Makefile
+++ b/
arch/mips/Makefile
@@
-14,8
+14,6
@@
KBUILD_DEFCONFIG := ip22_defconfig
-cflags-y := -ffunction-sections
-
#
# Select the object file format to substitute into the linker script.
#
@@
-50,6
+48,8
@@
ifneq ($(SUBARCH),$(ARCH))
endif
endif
+cflags-y := -ffunction-sections
+
ifdef CONFIG_32BIT
ld-emul = $(32bit-emul)
vmlinux-32 = vmlinux