projects
/
openwrt
/
staging
/
hauke.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
d39a6c6
)
imagebuilder: fix broken image generation with external targets
author
Petr Štetiar
<ynezz@true.cz>
Thu, 24 Mar 2022 05:52:37 +0000
(06:52 +0100)
committer
Petr Štetiar
<ynezz@true.cz>
Tue, 5 Apr 2022 20:09:35 +0000
(22:09 +0200)
When using external targets there is a symlink being created for the
target under target/linux which then becomes dangling under Image
Builder. Fix it by dereferencing the possible symlink.
Tested on IB with external target, ipq40xx and mvebu.
Signed-off-by: Petr Štetiar <ynezz@true.cz>
(cherry picked from commit
621f39d1f438bf95dbae667c575926fa16a6d797
)
(cherry picked from commit
ec9af870f3278f75549836b469baefa260e2ed41
)
(cherry picked from commit
3008f1f441a41e162311cee1ccadfdaaec1581c1
)
target/imagebuilder/Makefile
patch
|
blob
|
history
diff --git
a/target/imagebuilder/Makefile
b/target/imagebuilder/Makefile
index f1f25fc7c43558e1d246205cbbf17147370f79cd..4246bed1ea178440e03837407c5760107ebcfdde 100644
(file)
--- a/
target/imagebuilder/Makefile
+++ b/
target/imagebuilder/Makefile
@@
-57,7
+57,7
@@
else
find $(wildcard $(PACKAGE_SUBDIRS)) -type f -name '*.ipk' -exec $(CP) {} $(PKG_BUILD_DIR)/packages/ \;
endif
- $(CP) $(TOPDIR)/target/linux $(PKG_BUILD_DIR)/target/
+ $(CP)
-L
$(TOPDIR)/target/linux $(PKG_BUILD_DIR)/target/
if [ -d $(TOPDIR)/staging_dir/host/lib/grub ]; then \
$(CP) $(TOPDIR)/staging_dir/host/lib/grub/ $(PKG_BUILD_DIR)/staging_dir/host/lib; \
fi