ifeq ($(LINUX_VERSION),2.6.28.10)
LINUX_KERNEL_MD5SUM:=c4efb2c494d749cb5de274f8ae41c3fa
endif
-ifeq ($(LINUX_VERSION),2.6.30.7)
- LINUX_KERNEL_MD5SUM:=40ac5c687ffd7b4d456fa61e7b250911
+ifeq ($(LINUX_VERSION),2.6.30.8)
+ LINUX_KERNEL_MD5SUM:=76b8397bfb477788b26c834f71e27df6
endif
ifeq ($(LINUX_VERSION),2.6.31.1)
LINUX_KERNEL_MD5SUM:=8077cd7f7c1cdeb6aef3872441ae5294
BOARDNAME:=TI AR7
FEATURES:=squashfs jffs2 atm
-LINUX_VERSION:=2.6.30.7
+LINUX_VERSION:=2.6.30.8
include $(INCLUDE_DIR)/target.mk
FEATURES:=squashfs jffs2 tgz
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
-LINUX_VERSION:=2.6.30.7
+LINUX_VERSION:=2.6.30.8
include $(INCLUDE_DIR)/target.mk
--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
-@@ -603,6 +603,13 @@ else
- load-$(CONFIG_CPU_CAVIUM_OCTEON) += 0xffffffff81100000
+@@ -607,6 +607,13 @@ ifdef CONFIG_PHYSICAL_START
+ load-y = $(CONFIG_PHYSICAL_START)
endif
+#
static int __init ag71xx_probe(struct platform_device *pdev)
{
struct net_device *dev;
-@@ -875,14 +887,9 @@ static int __init ag71xx_probe(struct pl
+@@ -861,14 +873,9 @@ static int __init ag71xx_probe(struct pl
}
dev->base_addr = (unsigned long)ag->mac_base;
--- a/arch/mips/ar71xx/devices.c
+++ b/arch/mips/ar71xx/devices.c
-@@ -790,6 +790,8 @@ static struct platform_device ar71xx_dsa
+@@ -780,6 +780,8 @@ static struct platform_device ar71xx_dsa
void __init ar71xx_add_device_dsa(unsigned int id,
struct dsa_platform_data *d)
{
switch (id) {
case 0:
d->netdev = &ar71xx_eth0_device.dev;
-@@ -803,7 +805,10 @@ void __init ar71xx_add_device_dsa(unsign
+@@ -793,7 +795,10 @@ void __init ar71xx_add_device_dsa(unsign
id);
return;
}
BOARDNAME:=Atheros AR231x/AR5312
FEATURES:=squashfs jffs2
-LINUX_VERSION:=2.6.30.7
+LINUX_VERSION:=2.6.30.8
include $(INCLUDE_DIR)/target.mk
FEATURES:=jffs2 usb pci
SUBTARGETS=au1500 au1550
-LINUX_VERSION:=2.6.30.7
+LINUX_VERSION:=2.6.30.8
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += hostapd-mini yamonenv
-Index: linux-2.6.30.1/drivers/net/au1000_eth.c
-===================================================================
---- linux-2.6.30.1.orig/drivers/net/au1000_eth.c 2009-07-03 01:52:38.000000000 +0200
-+++ linux-2.6.30.1/drivers/net/au1000_eth.c 2009-07-18 12:26:58.000000000 +0200
-@@ -1036,10 +1036,14 @@
+--- a/drivers/net/au1000_eth.c
++++ b/drivers/net/au1000_eth.c
+@@ -1036,10 +1036,14 @@ static void au1000_multicast_list(struct
}
}
--- a/drivers/net/au1000_eth.c
+++ b/drivers/net/au1000_eth.c
-@@ -184,6 +184,15 @@ struct au1000_private *au_macs[NUM_ETH_I
+@@ -166,6 +166,15 @@ struct au1000_private *au_macs[NUM_ETH_I
# undef AU1XXX_PHY1_IRQ
#endif
#if defined(AU1XXX_PHY0_BUSID) && (AU1XXX_PHY0_BUSID > 0)
# error MAC0-associated PHY attached 2nd MACs MII bus not supported yet
#endif
-@@ -380,6 +389,12 @@ static int mii_probe (struct net_device
+@@ -483,6 +492,12 @@ static int mii_probe (struct net_device
aup->old_duplex = -1;
aup->phy_dev = phydev;
+#endif
+
printk(KERN_INFO "%s: attached PHY driver [%s] "
- "(mii_bus:phy_addr=%s, irq=%d)\n",
- dev->name, phydev->drv->name, phydev->dev.bus_id, phydev->irq);
+ "(mii_bus:phy_addr=%s, irq=%d)\n", dev->name,
+ phydev->drv->name, dev_name(&phydev->dev), phydev->irq);
-diff --git a/arch/mips/alchemy/mtx-1/platform.c b/arch/mips/alchemy/mtx-1/platform.c
-index 8b5914d..e30e42a 100644
--- a/arch/mips/alchemy/mtx-1/platform.c
+++ b/arch/mips/alchemy/mtx-1/platform.c
@@ -1,7 +1,7 @@
*
* This program is free software; you can redistribute it and/or modify
* it under the terms of the GNU General Public License as published by
-@@ -142,7 +142,17 @@ static struct __initdata platform_device * mtx1_devs[] = {
+@@ -142,7 +142,17 @@ static struct __initdata platform_device
static int __init mtx1_register_devices(void)
{
BOARD:=avr32
BOARDNAME:=Atmel AVR32
FEATURES:=squashfs
-LINUX_VERSION:=2.6.30.7
+LINUX_VERSION:=2.6.30.8
include $(INCLUDE_DIR)/target.mk
BOARDNAME:=Broadcom BCM947xx/953xx
FEATURES:=squashfs usb
-LINUX_VERSION:=2.6.30.7
+LINUX_VERSION:=2.6.30.8
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += hostapd-mini kmod-switch kmod-diag nvram
BOARDNAME:=Cobalt Microservers
FEATURES:=tgz pci ext2
-LINUX_VERSION:=2.6.30.7
+LINUX_VERSION:=2.6.30.8
include $(INCLUDE_DIR)/target.mk
BOARD:=etrax
BOARDNAME:=Foxboard (ETRAX 100LX)
FEATURES:=squashfs jffs2
-LINUX_VERSION:=2.6.30.7
+LINUX_VERSION:=2.6.30.8
DEVICE_TYPE=
include $(INCLUDE_DIR)/target.mk
-Index: linux-2.6.30-rc5/drivers/usb/host/Makefile
-===================================================================
---- linux-2.6.30-rc5.orig/drivers/usb/host/Makefile 2009-05-09 02:14:14.000000000 +0200
-+++ linux-2.6.30-rc5/drivers/usb/host/Makefile 2009-05-13 14:07:10.000000000 +0200
-@@ -25,6 +25,7 @@
+--- a/drivers/usb/host/Makefile
++++ b/drivers/usb/host/Makefile
+@@ -25,6 +25,7 @@ obj-$(CONFIG_USB_UHCI_HCD) += uhci-hcd.o
obj-$(CONFIG_USB_FHCI_HCD) += fhci.o
obj-$(CONFIG_USB_SL811_HCD) += sl811-hcd.o
obj-$(CONFIG_USB_SL811_CS) += sl811_cs.o
obj-$(CONFIG_USB_U132_HCD) += u132-hcd.o
obj-$(CONFIG_USB_R8A66597_HCD) += r8a66597-hcd.o
obj-$(CONFIG_USB_ISP1760_HCD) += isp1760.o
-Index: linux-2.6.30-rc5/drivers/usb/Makefile
-===================================================================
---- linux-2.6.30-rc5.orig/drivers/usb/Makefile 2009-05-13 14:06:45.000000000 +0200
-+++ linux-2.6.30-rc5/drivers/usb/Makefile 2009-05-13 14:07:10.000000000 +0200
-@@ -20,6 +20,7 @@
+--- a/drivers/usb/Makefile
++++ b/drivers/usb/Makefile
+@@ -19,6 +19,7 @@ obj-$(CONFIG_USB_U132_HCD) += host/
obj-$(CONFIG_USB_R8A66597_HCD) += host/
obj-$(CONFIG_USB_HWA_HCD) += host/
obj-$(CONFIG_USB_ISP1760_HCD) += host/
FEATURES:=squashfs
CFLAGS:=-Os -pipe -march=armv4 -mtune=arm9tdmi -funit-at-a-time
-LINUX_VERSION:=2.6.30.7
+LINUX_VERSION:=2.6.30.8
include $(INCLUDE_DIR)/target.mk
+#endif
#define L1_CACHE_BYTES (1 << L1_CACHE_SHIFT)
- #endif
+ /*
--- a/arch/arm/include/asm/dma-mapping.h
+++ b/arch/arm/include/asm/dma-mapping.h
@@ -98,7 +98,7 @@ static inline int dma_set_mask(struct de
__initramfs_start = .;
usr/built-in.o(.init.ramfs)
__initramfs_end = .;
-@@ -165,13 +166,13 @@ SECTIONS
+@@ -153,13 +154,13 @@ SECTIONS
/*
* then the cacheline aligned data
*/
+};
--- a/drivers/usb/host/ehci.h
+++ b/drivers/usb/host/ehci.h
-@@ -541,7 +541,12 @@ static inline unsigned int
+@@ -543,7 +543,12 @@ static inline unsigned int
ehci_port_speed(struct ehci_hcd *ehci, unsigned int portsc)
{
if (ehci_is_TDI(ehci)) {
/* generic layer kills/unlinks all urbs, then
* uses ehci_stop to clean up the rest
*/
-@@ -1042,6 +1052,11 @@ MODULE_LICENSE ("GPL");
+@@ -1045,6 +1055,11 @@ MODULE_LICENSE ("GPL");
#define PCI_DRIVER ehci_pci_driver
#endif
Signed-off-by: Florian Fainelli <florian@openwrt.org>
--
-Index: linux-2.6.30.7/arch/mips/Kconfig
-===================================================================
---- linux-2.6.30.7.orig/arch/mips/Kconfig 2009-09-28 08:21:26.000000000 +0200
-+++ linux-2.6.30.7/arch/mips/Kconfig 2009-09-28 08:21:31.000000000 +0200
-@@ -791,6 +791,17 @@
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -791,6 +791,17 @@ config I8259
config MIPS_BONITO64
bool
config MIPS_MSC
bool
-Index: linux-2.6.30.7/arch/mips/math-emu/Makefile
-===================================================================
---- linux-2.6.30.7.orig/arch/mips/math-emu/Makefile 2009-09-28 08:21:26.000000000 +0200
-+++ linux-2.6.30.7/arch/mips/math-emu/Makefile 2009-09-28 08:21:31.000000000 +0200
+--- a/arch/mips/math-emu/Makefile
++++ b/arch/mips/math-emu/Makefile
@@ -2,12 +2,14 @@
# Makefile for the Linux/MIPS kernel FPU emulation.
#
+ dp_sqrt.o sp_sqrt.o
EXTRA_CFLAGS += -Werror
-Index: linux-2.6.30.7/arch/mips/math-emu/cp1emu.c
-===================================================================
---- linux-2.6.30.7.orig/arch/mips/math-emu/cp1emu.c 2009-09-28 08:21:26.000000000 +0200
-+++ linux-2.6.30.7/arch/mips/math-emu/cp1emu.c 2009-09-28 08:21:31.000000000 +0200
+--- a/arch/mips/math-emu/cp1emu.c
++++ b/arch/mips/math-emu/cp1emu.c
@@ -56,6 +56,12 @@
#endif
#define __mips 4
/* Function which emulates a floating point instruction. */
static int fpu_emu(struct pt_regs *, struct mips_fpu_struct *,
-@@ -66,10 +72,6 @@
+@@ -66,10 +72,6 @@ static int fpux_emu(struct pt_regs *,
struct mips_fpu_struct *, mips_instruction);
#endif
/* Control registers */
#define FPCREG_RID 0 /* $0 = revision id */
-@@ -1273,6 +1275,13 @@
+@@ -1273,6 +1275,13 @@ int fpu_emulator_cop1Handler(struct pt_r
return sig;
}
#ifdef CONFIG_DEBUG_FS
extern struct dentry *mips_debugfs_dir;
-Index: linux-2.6.30.7/arch/mips/math-emu/dsemul.c
-===================================================================
---- linux-2.6.30.7.orig/arch/mips/math-emu/dsemul.c 2009-09-28 08:21:26.000000000 +0200
-+++ linux-2.6.30.7/arch/mips/math-emu/dsemul.c 2009-09-28 08:21:31.000000000 +0200
-@@ -109,6 +109,7 @@
+--- a/arch/mips/math-emu/dsemul.c
++++ b/arch/mips/math-emu/dsemul.c
+@@ -109,6 +109,7 @@ int mips_dsemul(struct pt_regs *regs, mi
return SIGILL; /* force out of emulation loop */
}
int do_dsemulret(struct pt_regs *xcp)
{
struct emuframe __user *fr;
-@@ -165,3 +166,9 @@
+@@ -165,3 +166,9 @@ int do_dsemulret(struct pt_regs *xcp)
return 1;
}
+ return 0;
+}
+#endif /* CONFIG_MIPS_FPU_EMU */
-Index: linux-2.6.30.7/arch/mips/math-emu/kernel_linkage.c
-===================================================================
---- linux-2.6.30.7.orig/arch/mips/math-emu/kernel_linkage.c 2009-09-28 08:21:26.000000000 +0200
-+++ linux-2.6.30.7/arch/mips/math-emu/kernel_linkage.c 2009-09-28 08:22:36.000000000 +0200
+--- a/arch/mips/math-emu/kernel_linkage.c
++++ b/arch/mips/math-emu/kernel_linkage.c
@@ -29,6 +29,7 @@
#define SIGNALLING_NAN 0x7ff800007ff80000LL
void fpu_emulator_init_fpu(void)
{
static int first = 1;
-@@ -112,4 +113,36 @@
+@@ -112,4 +113,36 @@ int fpu_emulator_restore_context32(struc
return err;
}
arch/mips/include/asm/kexec.h | 21 20 + 1 - 0 !
9 files changed, 399 insertions(+), 10 deletions(-)
-Index: linux-2.6.30.7/arch/mips/Kconfig
-===================================================================
---- linux-2.6.30.7.orig/arch/mips/Kconfig 2009-09-27 20:41:06.000000000 +0200
-+++ linux-2.6.30.7/arch/mips/Kconfig 2009-09-27 21:02:55.000000000 +0200
-@@ -1966,6 +1966,29 @@
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -1966,6 +1966,29 @@ config KEXEC
support. As of this writing the exact hardware interface is
strongly in flux, so no good recommendation can be made.
config SECCOMP
bool "Enable seccomp to safely compute untrusted bytecode"
depends on PROC_FS
-Index: linux-2.6.30.7/arch/mips/Makefile
-===================================================================
---- linux-2.6.30.7.orig/arch/mips/Makefile 2009-09-27 20:41:07.000000000 +0200
-+++ linux-2.6.30.7/arch/mips/Makefile 2009-09-27 21:03:31.000000000 +0200
-@@ -603,6 +603,10 @@
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -603,6 +603,10 @@ else
load-$(CONFIG_CPU_CAVIUM_OCTEON) += 0xffffffff81100000
endif
cflags-y += -I$(srctree)/arch/mips/include/asm/mach-generic
drivers-$(CONFIG_PCI) += arch/mips/pci/
-Index: linux-2.6.30.7/arch/mips/kernel/Makefile
-===================================================================
---- linux-2.6.30.7.orig/arch/mips/kernel/Makefile 2009-09-27 20:41:06.000000000 +0200
-+++ linux-2.6.30.7/arch/mips/kernel/Makefile 2009-09-27 21:02:55.000000000 +0200
-@@ -83,7 +83,8 @@
+--- a/arch/mips/kernel/Makefile
++++ b/arch/mips/kernel/Makefile
+@@ -83,7 +83,8 @@ obj-$(CONFIG_I8253) += i8253.o
obj-$(CONFIG_GPIO_TXX9) += gpio_txx9.o
obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
obj-$(CONFIG_MIPS_MACHINE) += mips_machine.o
-Index: linux-2.6.30.7/arch/mips/kernel/crash.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.30.7/arch/mips/kernel/crash.c 2009-09-27 21:02:55.000000000 +0200
+--- /dev/null
++++ b/arch/mips/kernel/crash.c
@@ -0,0 +1,90 @@
+/*
+ * Architecture specific (MIPS) functions for kexec based crash dumps.
+ crash_kexec_prepare_cpus();
+ cpu_set(crashing_cpu, cpus_in_crash);
+}
-Index: linux-2.6.30.7/arch/mips/kernel/crash_dump.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.30.7/arch/mips/kernel/crash_dump.c 2009-09-27 21:02:55.000000000 +0200
+--- /dev/null
++++ b/arch/mips/kernel/crash_dump.c
@@ -0,0 +1,96 @@
+/*
+ * Routines for doing kexec-based kdump.
+ return ret;
+}
+arch_initcall(kdump_buf_page_init);
-Index: linux-2.6.30.7/arch/mips/kernel/machine_kexec.c
-===================================================================
---- linux-2.6.30.7.orig/arch/mips/kernel/machine_kexec.c 2009-09-15 19:46:05.000000000 +0200
-+++ linux-2.6.30.7/arch/mips/kernel/machine_kexec.c 2009-09-27 21:02:55.000000000 +0200
-@@ -19,9 +19,25 @@
+--- a/arch/mips/kernel/machine_kexec.c
++++ b/arch/mips/kernel/machine_kexec.c
+@@ -19,9 +19,25 @@ extern const size_t relocate_new_kernel_
extern unsigned long kexec_start_address;
extern unsigned long kexec_indirection_page;
return 0;
}
-@@ -33,13 +49,18 @@
+@@ -33,13 +49,18 @@ machine_kexec_cleanup(struct kimage *kim
void
machine_shutdown(void)
{
typedef void (*noretfun_t)(void) __attribute__((noreturn));
void
-@@ -52,7 +73,9 @@
+@@ -52,7 +73,9 @@ machine_kexec(struct kimage *image)
reboot_code_buffer =
(unsigned long)page_address(image->control_code_page);
kexec_indirection_page =
(unsigned long) phys_to_virt(image->head & PAGE_MASK);
-@@ -63,7 +86,7 @@
+@@ -63,7 +86,7 @@ machine_kexec(struct kimage *image)
* The generic kexec code builds a page list with physical
* addresses. they are directly accessible through KSEG0 (or
* CKSEG0 or XPHYS if on 64bit system), hence the
*/
for (ptr = &image->head; (entry = *ptr) && !(entry &IND_DONE);
ptr = (entry & IND_INDIRECTION) ?
-@@ -78,8 +101,39 @@
+@@ -78,8 +101,39 @@ machine_kexec(struct kimage *image)
*/
local_irq_disable();
+ return 0;
}
+early_param("crashkernel", parse_crashkernel_cmdline);
-Index: linux-2.6.30.7/arch/mips/kernel/relocate_kernel.S
-===================================================================
---- linux-2.6.30.7.orig/arch/mips/kernel/relocate_kernel.S 2009-09-15 19:46:05.000000000 +0200
-+++ linux-2.6.30.7/arch/mips/kernel/relocate_kernel.S 2009-09-27 21:02:55.000000000 +0200
+--- a/arch/mips/kernel/relocate_kernel.S
++++ b/arch/mips/kernel/relocate_kernel.S
@@ -14,7 +14,13 @@
#include <asm/stackframe.h>
#include <asm/addrspace.h>
PTR_L s0, kexec_indirection_page
PTR_L s1, kexec_start_address
-@@ -26,7 +32,6 @@
+@@ -26,7 +32,6 @@ process_entry:
and s3, s2, 0x1
beq s3, zero, 1f
and s4, s2, ~0x1 /* store destination addr in s4 */
b process_entry
1:
-@@ -40,6 +45,7 @@
+@@ -40,6 +45,7 @@ process_entry:
/* done page */
and s3, s2, 0x4
beq s3, zero, 1f
b done
1:
/* source page */
-@@ -56,14 +62,102 @@
+@@ -56,14 +62,102 @@ copy_word:
PTR_ADD s2, s2, SZREG
LONG_SUB s6, s6, 1
beq s6, zero, process_entry
kexec_start_address:
EXPORT(kexec_start_address)
PTR 0x0
-Index: linux-2.6.30.7/arch/mips/kernel/setup.c
-===================================================================
---- linux-2.6.30.7.orig/arch/mips/kernel/setup.c 2009-09-15 19:46:05.000000000 +0200
-+++ linux-2.6.30.7/arch/mips/kernel/setup.c 2009-09-27 21:02:55.000000000 +0200
+--- a/arch/mips/kernel/setup.c
++++ b/arch/mips/kernel/setup.c
@@ -21,7 +21,7 @@
#include <linux/console.h>
#include <linux/pfn.h>
#include <asm/addrspace.h>
#include <asm/bootinfo.h>
#include <asm/bugs.h>
-@@ -489,6 +489,11 @@
+@@ -489,6 +489,11 @@ static void __init arch_mem_init(char **
}
bootmem_init();
sparse_init();
paging_init();
}
-@@ -543,6 +548,9 @@
+@@ -543,6 +548,9 @@ static void __init resource_init(void)
*/
request_resource(res, &code_resource);
request_resource(res, &data_resource);
}
}
-Index: linux-2.6.30.7/arch/mips/include/asm/kexec.h
-===================================================================
---- linux-2.6.30.7.orig/arch/mips/include/asm/kexec.h 2009-09-15 19:46:05.000000000 +0200
-+++ linux-2.6.30.7/arch/mips/include/asm/kexec.h 2009-09-27 21:02:55.000000000 +0200
+--- a/arch/mips/include/asm/kexec.h
++++ b/arch/mips/include/asm/kexec.h
@@ -9,6 +9,8 @@
#ifndef _MIPS_KEXEC
# define _MIPS_KEXEC
--- a/drivers/mtd/devices/block2mtd.c
+++ b/drivers/mtd/devices/block2mtd.c
-@@ -268,6 +268,7 @@
+@@ -268,6 +268,7 @@ static int _open_bdev(struct block2mtd_d
/* We might not have rootfs mounted at this point. Try
to resolve the device name by other means. */
--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
-@@ -603,6 +603,9 @@ else
- load-$(CONFIG_CPU_CAVIUM_OCTEON) += 0xffffffff81100000
+@@ -607,6 +607,9 @@ ifdef CONFIG_PHYSICAL_START
+ load-y = $(CONFIG_PHYSICAL_START)
endif
+# temporary until string.h is fixed
FEATURES:=
CFLAGS:=-O2 -pipe -march=armv5te -mtune=xscale -funit-at-a-time
-LINUX_VERSION:=2.6.30.7
+LINUX_VERSION:=2.6.30.8
DEVICE_TYPE=phone
drivers/staging/android/lowmemorykiller.c | 35 +++++++++++++++++-----------
1 files changed, 21 insertions(+), 14 deletions(-)
-diff --git a/drivers/staging/android/lowmemorykiller.c b/drivers/staging/android/lowmemorykiller.c
-index 3715d56..b9a2e84 100644
--- a/drivers/staging/android/lowmemorykiller.c
+++ b/drivers/staging/android/lowmemorykiller.c
-@@ -71,23 +71,30 @@ static int lowmem_shrink(int nr_to_scan, gfp_t gfp_mask)
+@@ -71,23 +71,30 @@ static int lowmem_shrink(int nr_to_scan,
}
if(nr_to_scan > 0)
lowmem_print(3, "lowmem_shrink %d, %x, ofree %d, ma %d\n", nr_to_scan, gfp_mask, other_free, min_adj);
}
if(selected != NULL) {
lowmem_print(1, "send sigkill to %d (%s), adj %d, size %d\n",
---
-1.6.2
-
drivers/staging/android/lowmemorykiller.c | 13 +++++++++----
1 files changed, 9 insertions(+), 4 deletions(-)
-diff --git a/drivers/staging/android/lowmemorykiller.c b/drivers/staging/android/lowmemorykiller.c
-index b9a2e84..b2ab7fa 100644
--- a/drivers/staging/android/lowmemorykiller.c
+++ b/drivers/staging/android/lowmemorykiller.c
-@@ -58,20 +58,25 @@ static int lowmem_shrink(int nr_to_scan, gfp_t gfp_mask)
+@@ -58,20 +58,25 @@ static int lowmem_shrink(int nr_to_scan,
int min_adj = OOM_ADJUST_MAX + 1;
int selected_tasksize = 0;
int array_size = ARRAY_SIZE(lowmem_adj);
if (nr_to_scan <= 0 || min_adj == OOM_ADJUST_MAX + 1) {
lowmem_print(5, "lowmem_shrink %d, %x, return %d\n", nr_to_scan, gfp_mask, rem);
return rem;
---
-1.6.2
-
create mode 100644 drivers/staging/android/timed_output.c
create mode 100644 drivers/staging/android/timed_output.h
-diff --git a/drivers/staging/android/Kconfig b/drivers/staging/android/Kconfig
-index 604bd1e..1784508 100644
--- a/drivers/staging/android/Kconfig
+++ b/drivers/staging/android/Kconfig
@@ -73,9 +73,13 @@ config ANDROID_RAM_CONSOLE_EARLY_SIZE
default n
config ANDROID_LOW_MEMORY_KILLER
-diff --git a/drivers/staging/android/Makefile b/drivers/staging/android/Makefile
-index 95209d6..8e057e6 100644
--- a/drivers/staging/android/Makefile
+++ b/drivers/staging/android/Makefile
@@ -1,5 +1,6 @@
+obj-$(CONFIG_ANDROID_TIMED_OUTPUT) += timed_output.o
obj-$(CONFIG_ANDROID_TIMED_GPIO) += timed_gpio.o
obj-$(CONFIG_ANDROID_LOW_MEMORY_KILLER) += lowmemorykiller.o
-diff --git a/drivers/staging/android/timed_gpio.c b/drivers/staging/android/timed_gpio.c
-index 33daff0..be7cdaa 100644
--- a/drivers/staging/android/timed_gpio.c
+++ b/drivers/staging/android/timed_gpio.c
@@ -20,13 +20,12 @@
if (!gpio_data)
return -ENOMEM;
-@@ -107,23 +98,26 @@ static int timed_gpio_probe(struct platform_device *pdev)
+@@ -107,23 +98,26 @@ static int timed_gpio_probe(struct platf
cur_gpio = &pdata->gpios[i];
gpio_dat = &gpio_data[i];
}
platform_set_drvdata(pdev, gpio_data);
-@@ -137,10 +131,8 @@ static int timed_gpio_remove(struct platform_device *pdev)
+@@ -137,10 +131,8 @@ static int timed_gpio_remove(struct plat
struct timed_gpio_data *gpio_data = platform_get_drvdata(pdev);
int i;
kfree(gpio_data);
-@@ -151,22 +143,18 @@ static struct platform_driver timed_gpio_driver = {
+@@ -151,22 +143,18 @@ static struct platform_driver timed_gpio
.probe = timed_gpio_probe,
.remove = timed_gpio_remove,
.driver = {
platform_driver_unregister(&timed_gpio_driver);
}
-diff --git a/drivers/staging/android/timed_gpio.h b/drivers/staging/android/timed_gpio.h
-index 78449b2..a0e15f8 100644
--- a/drivers/staging/android/timed_gpio.h
+++ b/drivers/staging/android/timed_gpio.h
@@ -16,10 +16,12 @@
u8 active_low;
};
-diff --git a/drivers/staging/android/timed_output.c b/drivers/staging/android/timed_output.c
-new file mode 100644
-index 0000000..62e7918
--- /dev/null
+++ b/drivers/staging/android/timed_output.c
@@ -0,0 +1,121 @@
+MODULE_AUTHOR("Mike Lockwood <lockwood@android.com>");
+MODULE_DESCRIPTION("timed output class driver");
+MODULE_LICENSE("GPL");
-diff --git a/drivers/staging/android/timed_output.h b/drivers/staging/android/timed_output.h
-new file mode 100644
-index 0000000..ec907ab
--- /dev/null
+++ b/drivers/staging/android/timed_output.h
@@ -0,0 +1,37 @@
+extern void timed_output_dev_unregister(struct timed_output_dev *dev);
+
+#endif
---
-1.6.2
-
extern int pid_max_min, pid_max_max;
extern int sysctl_drop_caches;
extern int percpu_pagelist_fraction;
-@@ -1109,6 +1110,14 @@ static struct ctl_table vm_table[] = {
+@@ -1138,6 +1139,14 @@ static struct ctl_table vm_table[] = {
.extra1 = &zero,
},
{
unsigned long __meminitdata nr_kernel_pages;
unsigned long __meminitdata nr_all_pages;
-@@ -1253,7 +1254,7 @@ int zone_watermark_ok(struct zone *z, in
+@@ -1258,7 +1259,7 @@ int zone_watermark_ok(struct zone *z, in
free_pages -= z->free_area[o].nr_free << o;
/* Require fewer higher order pages to be free */
--- a/mm/page_alloc.c
+++ b/mm/page_alloc.c
-@@ -2545,6 +2545,20 @@ static inline unsigned long wait_table_b
+@@ -2570,6 +2570,20 @@ static inline unsigned long wait_table_b
#define LONG_ALIGN(x) (((x)+(sizeof(long))-1)&~((sizeof(long))-1))
/*
* Mark a number of pageblocks as MIGRATE_RESERVE. The number
* of blocks reserved is based on zone->pages_min. The memory within the
* reserve will tend to store contiguous free pages. Setting min_free_kbytes
-@@ -2573,7 +2587,7 @@ static void setup_zone_migrate_reserve(s
+@@ -2598,7 +2612,7 @@ static void setup_zone_migrate_reserve(s
continue;
/* Blocks with reserved pages will never free, skip them. */
--- a/kernel/sched.c
+++ b/kernel/sched.c
-@@ -9064,13 +9064,23 @@ void __init sched_init(void)
+@@ -9065,13 +9065,23 @@ void __init sched_init(void)
}
#ifdef CONFIG_DEBUG_SPINLOCK_SLEEP
--- a/arch/arm/kernel/signal.c
+++ b/arch/arm/kernel/signal.c
-@@ -534,6 +534,14 @@ setup_rt_frame(int usig, struct k_sigact
+@@ -499,6 +499,14 @@ setup_rt_frame(int usig, struct k_sigact
static inline void restart_syscall(struct pt_regs *regs)
{
regs->ARM_r0 = regs->ARM_ORIG_r0;
regs->ARM_pc -= thumb_mode(regs) ? 2 : 4;
}
-@@ -650,6 +658,7 @@ static int do_signal(sigset_t *oldset, s
+@@ -631,6 +639,7 @@ static void do_signal(struct pt_regs *re
*/
if (syscall) {
if (regs->ARM_r0 == -ERESTART_RESTARTBLOCK) {
create mode 100644 drivers/mtd/devices/goldfish_nand.c
create mode 100644 drivers/mtd/devices/goldfish_nand_reg.h
-diff --git a/drivers/mtd/devices/Kconfig b/drivers/mtd/devices/Kconfig
-index 6fde0a2..0e9bdd7 100644
--- a/drivers/mtd/devices/Kconfig
+++ b/drivers/mtd/devices/Kconfig
@@ -297,5 +297,10 @@ config MTD_DOCPROBE_55AA
+
endmenu
-diff --git a/drivers/mtd/devices/Makefile b/drivers/mtd/devices/Makefile
-index 0993d5c..46cf8a8 100644
--- a/drivers/mtd/devices/Makefile
+++ b/drivers/mtd/devices/Makefile
@@ -16,3 +16,4 @@ obj-$(CONFIG_MTD_LART) += lart.o
obj-$(CONFIG_MTD_DATAFLASH) += mtd_dataflash.o
obj-$(CONFIG_MTD_M25P80) += m25p80.o
+obj-$(CONFIG_MTD_GOLDFISH_NAND) += goldfish_nand.o
-diff --git a/drivers/mtd/devices/goldfish_nand.c b/drivers/mtd/devices/goldfish_nand.c
-new file mode 100644
-index 0000000..6b4b8b1
--- /dev/null
+++ b/drivers/mtd/devices/goldfish_nand.c
@@ -0,0 +1,418 @@
+module_init(goldfish_nand_init);
+module_exit(goldfish_nand_exit);
+
-diff --git a/drivers/mtd/devices/goldfish_nand_reg.h b/drivers/mtd/devices/goldfish_nand_reg.h
-new file mode 100644
-index 0000000..7c17a44
--- /dev/null
+++ b/drivers/mtd/devices/goldfish_nand_reg.h
@@ -0,0 +1,58 @@
+};
+
+#endif
---
-1.6.2
-
3 files changed, 261 insertions(+), 1 deletions(-)
create mode 100644 drivers/power/goldfish_battery.c
-diff --git a/drivers/power/Kconfig b/drivers/power/Kconfig
-index 33da112..593c616 100644
--- a/drivers/power/Kconfig
+++ b/drivers/power/Kconfig
@@ -88,4 +88,9 @@ config CHARGER_PCF50633
+ Say Y to enable support for the battery and AC power in the Goldfish emulator.
+
endif # POWER_SUPPLY
-diff --git a/drivers/power/Makefile b/drivers/power/Makefile
-index 2fcf41d..5be0fbb 100644
--- a/drivers/power/Makefile
+++ b/drivers/power/Makefile
@@ -19,10 +19,11 @@ obj-$(CONFIG_APM_POWER) += apm_power.o
-obj-$(CONFIG_CHARGER_PCF50633) += pcf50633-charger.o
\ No newline at end of file
+obj-$(CONFIG_CHARGER_PCF50633) += pcf50633-charger.o
-diff --git a/drivers/power/goldfish_battery.c b/drivers/power/goldfish_battery.c
-new file mode 100644
-index 0000000..868dc83
--- /dev/null
+++ b/drivers/power/goldfish_battery.c
@@ -0,0 +1,254 @@
+MODULE_AUTHOR("Mike Lockwood lockwood@android.com");
+MODULE_LICENSE("GPL");
+MODULE_DESCRIPTION("Battery driver for the Goldfish emulator");
---
-1.6.2
-
/* Avoid "noreturn function does return". */
--- a/kernel/fork.c
+++ b/kernel/fork.c
-@@ -1333,6 +1333,10 @@ struct task_struct * __cpuinit fork_idle
+@@ -1323,6 +1323,10 @@ struct task_struct * __cpuinit fork_idle
return task;
}
/*
* Ok, this is the main fork-routine.
*
-@@ -1434,6 +1438,10 @@ long do_fork(unsigned long clone_flags,
+@@ -1424,6 +1428,10 @@ long do_fork(unsigned long clone_flags,
tracehook_report_clone_complete(trace, regs,
clone_flags, nr, p);
wait_for_completion(&vfork);
--- a/kernel/sched.c
+++ b/kernel/sched.c
-@@ -2747,6 +2747,10 @@ asmlinkage void schedule_tail(struct tas
+@@ -2748,6 +2748,10 @@ asmlinkage void schedule_tail(struct tas
put_user(task_pid_vnr(current), current->set_child_tid);
}
/*
* context_switch - switch to the new MM and the new
* thread's register state.
-@@ -2789,6 +2793,11 @@ context_switch(struct rq *rq, struct tas
+@@ -2790,6 +2794,11 @@ context_switch(struct rq *rq, struct tas
spin_release(&rq->lock.dep_map, 1, _THIS_IP_);
#endif
--- a/mm/mmap.c
+++ b/mm/mmap.c
-@@ -903,6 +903,11 @@ void vm_stat_account(struct mm_struct *m
+@@ -906,6 +906,11 @@ void vm_stat_account(struct mm_struct *m
}
#endif /* CONFIG_PROC_FS */
/*
* The caller must hold down_write(current->mm->mmap_sem).
*/
-@@ -1209,6 +1214,10 @@ munmap_back:
+@@ -1212,6 +1217,10 @@ munmap_back:
pgoff = vma->vm_pgoff;
vm_flags = vma->vm_flags;
if (vma_wants_writenotify(vma))
vma->vm_page_prot = vm_get_page_prot(vm_flags & ~VM_SHARED);
-@@ -1935,6 +1944,10 @@ int do_munmap(struct mm_struct *mm, unsi
+@@ -1938,6 +1947,10 @@ int do_munmap(struct mm_struct *mm, unsi
* Remove the vma's, and unmap the actual pages
*/
detach_vmas_to_be_unmapped(mm, vma, prev, end);
BOARDNAME:=Marvell Kirkwood
FEATURES:=tgz usb
-LINUX_VERSION:=2.6.30.7
+LINUX_VERSION:=2.6.30.8
include $(INCLUDE_DIR)/target.mk
BOARDNAME:=Freescale MPC52xx
FEATURES:=tgz ext2
-LINUX_VERSION:=2.6.30.7
+LINUX_VERSION:=2.6.30.8
LINUX_KARCH:=powerpc
include $(INCLUDE_DIR)/target.mk
FEATURES:=squashfs jffs2 pci
CFLAGS:=-Os -pipe -mtune=octeon -funit-at-a-time
-LINUX_VERSION:=2.6.30.7
+LINUX_VERSION:=2.6.30.8
include $(INCLUDE_DIR)/target.mk
FEATURES:=squashfs
SUBTARGETS=generic harddisk
-LINUX_VERSION:=2.6.30.7
+LINUX_VERSION:=2.6.30.8
include $(INCLUDE_DIR)/target.mk
FEATURES:=squashfs usb
CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=405
-LINUX_VERSION:=2.6.30.7
+LINUX_VERSION:=2.6.30.8
LINUX_KARCH:=powerpc
include $(INCLUDE_DIR)/target.mk
FEATURES:=squashfs
CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=440
-LINUX_VERSION:=2.6.30.7
+LINUX_VERSION:=2.6.30.8
LINUX_KARCH:=powerpc
include $(INCLUDE_DIR)/target.mk
--- a/arch/powerpc/boot/dts/canyonlands.dts
+++ b/arch/powerpc/boot/dts/canyonlands.dts
-@@ -247,28 +247,6 @@
+@@ -239,28 +239,6 @@
interrupts = <0x1 0x4>;
};
label = "env";
--- a/arch/powerpc/boot/dts/canyonlands.dts
+++ b/arch/powerpc/boot/dts/canyonlands.dts
-@@ -209,24 +209,12 @@
+@@ -187,24 +187,12 @@
#address-cells = <1>;
#size-cells = <1>;
partition@0 {
SUBTARGETS=petitboot
FEATURES+=powerpc64
-LINUX_VERSION:=2.6.30.7
+LINUX_VERSION:=2.6.30.8
KERNEL_CC:=
--- a/drivers/net/ps3_gelic_net.c
+++ b/drivers/net/ps3_gelic_net.c
-@@ -970,10 +970,6 @@ static int gelic_card_decode_one_descr(s
+@@ -969,10 +969,6 @@ static int gelic_card_decode_one_descr(s
int dmac_chain_ended;
status = gelic_descr_get_status(descr);
if (status == GELIC_DESCR_DMA_CARDOWNED)
return 0;
-@@ -1036,6 +1032,11 @@ static int gelic_card_decode_one_descr(s
+@@ -1035,6 +1031,11 @@ static int gelic_card_decode_one_descr(s
/* ok, we've got a packet in descr */
gelic_net_pass_skb_up(descr, card, netdev);
refill:
/*
* So that always DMAC can see the end
* of the descriptor chain to avoid
-@@ -1064,10 +1065,9 @@ refill:
+@@ -1063,10 +1064,9 @@ refill:
* If dmac chain was met, DMAC stopped.
* thus re-enable it
*/
return 1;
}
-@@ -1133,11 +1133,6 @@ static irqreturn_t gelic_card_interrupt(
+@@ -1132,11 +1132,6 @@ static irqreturn_t gelic_card_interrupt(
status &= card->irq_mask;
BOARDNAME:=PowerXCell Accelerator Board
FEATURES+=powerpc64 fpu ramdisk
-LINUX_VERSION:=2.6.30.7
+LINUX_VERSION:=2.6.30.8
KERNEL_CC:=
CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
FEATURES:=squashfs broken
-LINUX_VERSION:=2.6.30.7
+LINUX_VERSION:=2.6.30.8
include $(INCLUDE_DIR)/target.mk
--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
-@@ -603,6 +603,26 @@
- load-$(CONFIG_CPU_CAVIUM_OCTEON) += 0xffffffff81100000
+@@ -607,6 +607,26 @@ ifdef CONFIG_PHYSICAL_START
+ load-y = $(CONFIG_PHYSICAL_START)
endif
+#
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
-@@ -22,6 +22,9 @@
+@@ -22,6 +22,9 @@ choice
config MACH_ALCHEMY
bool "Alchemy processor based machines"
config BASLER_EXCITE
bool "Basler eXcite smart camera"
select CEVT_R4K
-@@ -638,6 +641,7 @@
+@@ -638,6 +641,7 @@ source "arch/mips/basler/excite/Kconfig"
source "arch/mips/jazz/Kconfig"
source "arch/mips/lasat/Kconfig"
source "arch/mips/pmc-sierra/Kconfig"
source "arch/mips/sgi-ip27/Kconfig"
source "arch/mips/sibyte/Kconfig"
source "arch/mips/txx9/Kconfig"
-@@ -988,7 +992,7 @@
+@@ -989,7 +993,7 @@ config BOOT_ELF32
config MIPS_L1_CACHE_SHIFT
int
BOARDNAME:=Mikrotik RouterBoard 532
FEATURES:=jffs2 pci tgz
-LINUX_VERSION:=2.6.30.7
+LINUX_VERSION:=2.6.30.8
include $(INCLUDE_DIR)/target.mk
DEFAULT_PACKAGES += hostapd-mini kmod-madwifi
FEATURES:=jffs2
CFLAGS:=-O2 -pipe -march=armv4t -mtune=arm920t -funit-at-a-time
-LINUX_VERSION:=2.6.30.7
+LINUX_VERSION:=2.6.30.8
DEVICE_TYPE=phone
--- a/init/main.c
+++ b/init/main.c
-@@ -830,11 +830,11 @@ static noinline int init_post(void)
+@@ -831,11 +831,11 @@ static noinline int init_post(void)
* The Bourne shell can be used instead of init if we are
* trying to recover a really broken machine.
*/
FEATURES:=fpu
CFLAGS:=-Os -pipe -march=sb1 -funit-at-a-time
-LINUX_VERSION:=2.6.30.7
+LINUX_VERSION:=2.6.30.8
include $(INCLUDE_DIR)/target.mk
FEATURES:=ext2
LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
-LINUX_VERSION:=2.6.30.7
+LINUX_VERSION:=2.6.30.8
include $(INCLUDE_DIR)/target.mk