projects
/
openwrt
/
staging
/
robimarko.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
56172a1
)
only build avr32 u-boot if requested, fixes build failure in default config
author
Felix Fietkau
<nbd@openwrt.org>
Tue, 5 Aug 2008 01:01:27 +0000
(
01:01
+0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Tue, 5 Aug 2008 01:01:27 +0000
(
01:01
+0000)
SVN-Revision: 12116
target/linux/avr32/image/Makefile
patch
|
blob
|
history
diff --git
a/target/linux/avr32/image/Makefile
b/target/linux/avr32/image/Makefile
index 2cef2653bf1db6b0d3554e74219fc9b42346bb5a..c74efbe1df71f0dc5b97017924062258ff6f3261 100644
(file)
--- a/
target/linux/avr32/image/Makefile
+++ b/
target/linux/avr32/image/Makefile
@@
-8,13
+8,15
@@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-define Build/Clean
+ifneq ($(CONFIG_AVR32_UBOOT),)
+ define Build/Clean
$(MAKE) -C u-boot clean
-endef
+
endef
-define Build/Compile
+
define Build/Compile
$(MAKE) -C u-boot compile
-endef
+ endef
+endif
define Image/Prepare
cp $(LINUX_DIR)/arch/avr32/boot/images/uImage $(KDIR)/uImage