projects
/
openwrt
/
svn-archive
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
04007c7
)
fix for adding files to image builder make
author
Felix Fietkau
<nbd@openwrt.org>
Tue, 30 Aug 2005 21:53:44 +0000
(21:53 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Tue, 30 Aug 2005 21:53:44 +0000
(21:53 +0000)
SVN-Revision: 1802
openwrt/target/linux/imagebuilder/Makefile
patch
|
blob
|
history
diff --git
a/openwrt/target/linux/imagebuilder/Makefile
b/openwrt/target/linux/imagebuilder/Makefile
index 95b0939c4e47533610d05e702ac9175728ab1cd5..c70fb11e93dd4e15f21914d7ecf0c6b8e4cb4050 100644
(file)
--- a/
openwrt/target/linux/imagebuilder/Makefile
+++ b/
openwrt/target/linux/imagebuilder/Makefile
@@
-40,9
+40,9
@@
build:
$(IPKG_KERNEL) install `ls packages/$${package}_*`; \
done
if [ -d ./files ]; then \
- cp -
fpR
./files/* $(LINUX_BUILD_DIR)/root; \
+ cp -
a --remove-destination
./files/* $(LINUX_BUILD_DIR)/root; \
fi
if [ -d ./files.$(LIST) ]; then \
- cp -
fpR
./files.$(LIST)/* $(LINUX_BUILD_DIR)/root; \
+ cp -
a --remove-destination
./files.$(LIST)/* $(LINUX_BUILD_DIR)/root; \
fi
$(MAKE) -S -C image KERNEL="$(KERNEL)" BOARD="$(BOARD)" BIN_DIR="$(BIN_DIR)/$(LIST)" install