projects
/
openwrt
/
staging
/
robimarko.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
a4eb1ea
)
uboot-rockchip: add support for PINE64 ROCK64
author
Antonio Flores
<antflores627@gmail.com>
Sat, 8 Jul 2023 17:26:31 +0000
(13:26 -0400)
committer
Hauke Mehrtens
<hauke@hauke-m.de>
Sun, 27 Aug 2023 17:20:11 +0000
(19:20 +0200)
Add uboot support for PINE64 ROCK64, rockchip rk3328 board.
Signed-off-by: Antonio Flores <antflores627@gmail.com>
package/boot/uboot-rockchip/Makefile
patch
|
blob
|
history
diff --git
a/package/boot/uboot-rockchip/Makefile
b/package/boot/uboot-rockchip/Makefile
index 2d44c218f2496a2837a94756c990967f510bfca1..f424abbd4458a127127bfdcac98713335c523149 100644
(file)
--- a/
package/boot/uboot-rockchip/Makefile
+++ b/
package/boot/uboot-rockchip/Makefile
@@
-66,6
+66,13
@@
define U-Boot/roc-cc-rk3328
firefly_roc-rk3328-cc
endef
+define U-Boot/rock64-rk3328
+ $(U-Boot/rk3328/Default)
+ NAME:=Rock64
+ BUILD_DEVICES:= \
+ pine64_rock64
+endef
+
# RK3399 boards
define U-Boot/rk3399/Default
@@
-111,7
+118,8
@@
UBOOT_TARGETS := \
nanopi-r2s-rk3328 \
orangepi-r1-plus-rk3328 \
orangepi-r1-plus-lts-rk3328 \
- roc-cc-rk3328
+ roc-cc-rk3328 \
+ rock64-rk3328
UBOOT_CONFIGURE_VARS += USE_PRIVATE_LIBGCC=yes