include/package-pack: drop version from provides
authorPaul Spooren <mail@aparcar.org>
Sun, 27 Oct 2024 15:36:33 +0000 (16:36 +0100)
committerChristian Marangi <ansuelsmth@gmail.com>
Mon, 28 Oct 2024 23:07:55 +0000 (00:07 +0100)
Adding a version to the provides causes it to conflict with other
packages that provides the same package, further details are available
here: https://gitlab.alpinelinux.org/alpine/apk-tools/-/blob/master/doc/apk-package.5.scd#L199

This was intitally done, if I remember correctly, to support depending
on the specific kernel modules. Due to patches to APK, versions
containing hashes work now, too, so this is no longer required.

Only add the version to packages that define an ABI version since other
packages depend against the package name plus ABI version.

While at it, format the now rather complex call.

Fixes: https://github.com/openwrt/openwrt/issues/16795
Signed-off-by: Paul Spooren <mail@aparcar.org>
include/package-pack.mk

index 9991050c14c765427b0a1ff9ac7df23bf428e81b..a677318ca24e88ebeddc25817df0ff10b9769bcd 100644 (file)
@@ -345,8 +345,16 @@ else
          --info "origin:$(SOURCE)" \
          --info "url:$(URL)" \
          --info "maintainer:$(MAINTAINER)" \
-         --info "provides:$$(foreach prov,$$(filter-out $(1)$$(ABIV_$(1)),$(PROVIDES)$$(if $$(ABIV_$(1)), \
-               $(1) $(foreach provide,$(PROVIDES),$(provide)$$(ABIV_$(1))))),$$(prov)=$(VERSION) )" \
+         --info "provides:$$(foreach prov,\
+                       $$(filter-out $(1)$$(ABIV_$(1)), \
+                       $(PROVIDES)$$(if $$(ABIV_$(1)), \
+                               $(1)=$(VERSION) $(foreach provide, \
+                                       $(PROVIDES), \
+                                       $(provide)$$(ABIV_$(1))=$(VERSION) \
+                               ) \
+                       ) \
+               ), \
+               $$(prov) )" \
          --script "post-install:$$(ADIR_$(1))/post-install" \
          --script "pre-deinstall:$$(ADIR_$(1))/pre-deinstall" \
          --info "depends:$$(foreach depends,$$(subst $$(comma),$$(space),$$(subst $$(space),,$$(subst $$(paren_right),,$$(subst $$(paren_left),,$$(Package/$(1)/DEPENDS))))),$$(depends))" \