projects
/
openwrt
/
staging
/
hauke.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
033f02b
)
tools/e2fsprogs: fix build with clang
author
Felix Fietkau
<nbd@nbd.name>
Sat, 15 Sep 2018 13:49:31 +0000
(15:49 +0200)
committer
Felix Fietkau
<nbd@nbd.name>
Sat, 15 Sep 2018 13:49:43 +0000
(15:49 +0200)
Signed-off-by: Felix Fietkau <nbd@nbd.name>
tools/e2fsprogs/Makefile
patch
|
blob
|
history
diff --git
a/tools/e2fsprogs/Makefile
b/tools/e2fsprogs/Makefile
index fec6d834546567212923f64cc44dbef37a366837..f11ce52ca09c73a65574a98653780442dbbcdccb 100644
(file)
--- a/
tools/e2fsprogs/Makefile
+++ b/
tools/e2fsprogs/Makefile
@@
-20,6
+20,9
@@
HOST_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/host-build.mk
+ifneq ($(shell $(HOSTCC) --version | grep clang),)
+ HOST_CFLAGS += -D__GNUC_PREREQ\(...\)=0
+endif
HOST_CFLAGS += $(FPIC)
HOST_CONFIGURE_ARGS += \