projects
/
openwrt
/
staging
/
jow.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
894bd2f
)
proper series file support for regular packages
author
Felix Fietkau
<nbd@openwrt.org>
Sat, 29 Sep 2007 00:25:38 +0000
(
00:25
+0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Sat, 29 Sep 2007 00:25:38 +0000
(
00:25
+0000)
SVN-Revision: 9059
include/quilt.mk
patch
|
blob
|
history
diff --git
a/include/quilt.mk
b/include/quilt.mk
index 4dce2a6d8ca2ef59312ab255d8c3100b1a2ce941..c156d3062dec056a27def7dd412222e54440db6a 100644
(file)
--- a/
include/quilt.mk
+++ b/
include/quilt.mk
@@
-44,7
+44,12
@@
ifneq ($(QUILT),)
else
define Build/Patch/Default
@if [ -d $(PATCH_DIR) -a "$$$$(ls $(PATCH_DIR) | wc -l)" -gt 0 ]; then \
- $(PATCH) $(PKG_BUILD_DIR) $(PATCH_DIR); \
+ if [ -f $(PATCH_DIR)/series ]; then \
+ grep -vE '^#' $(PATCH_DIR)/series | xargs -n1 \
+ $(PATCH) $(PKG_BUILD_DIR) $(PATCH_DIR); \
+ else \
+ $(PATCH) $(PKG_BUILD_DIR) $(PATCH_DIR); \
+ fi; \
fi
endef
endif