projects
/
openwrt
/
staging
/
rmilecki.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
e5060b3
)
sdk: clean scripts/config before packing tarball (FS#504)
author
Felix Fietkau
<nbd@nbd.name>
Mon, 13 Feb 2017 10:45:43 +0000
(11:45 +0100)
committer
Felix Fietkau
<nbd@nbd.name>
Mon, 13 Feb 2017 10:47:12 +0000
(11:47 +0100)
Avoids shipping potentially incompatible object files and also reduces
the tarball size
Signed-off-by: Felix Fietkau <nbd@nbd.name>
target/sdk/Makefile
patch
|
blob
|
history
diff --git
a/target/sdk/Makefile
b/target/sdk/Makefile
index 5108cec441e5ddc4b1c6b1bb4fd5cdc40d484269..bec76e5ca88eb6ff8cb94106ab0df589d5f0b28b 100644
(file)
--- a/
target/sdk/Makefile
+++ b/
target/sdk/Makefile
@@
-137,6
+137,7
@@
$(BIN_DIR)/$(SDK_NAME).tar.xz: clean
find $(SDK_BUILD_DIR) -name .git | $(XARGS) rm -rf
find $(SDK_BUILD_DIR) -name .svn | $(XARGS) rm -rf
find $(SDK_BUILD_DIR) -name CVS | $(XARGS) rm -rf
+ -make -C $(SDK_BUILD_DIR)/scripts/config clean
(cd $(BUILD_DIR); \
tar -I 'xz -7e' -cf $@ $(SDK_NAME); \
)