kernel: bump 5.10 to 5.10.185
authorHauke Mehrtens <hauke@hauke-m.de>
Sat, 1 Jul 2023 12:31:42 +0000 (14:31 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 1 Jul 2023 12:31:42 +0000 (14:31 +0200)
Removed because upstreamed:
uml/patches-5.10/001-um-Fix-build-w-o-CONFIG_PM_SLEEP.patch

All other patches automatically rebased.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
20 files changed:
include/kernel-5.10
target/linux/ath79/patches-5.10/910-unaligned_access_hacks.patch
target/linux/bcm27xx/patches-5.10/950-0046-MMC-added-alternative-MMC-driver.patch
target/linux/bcm27xx/patches-5.10/950-0323-media-i2c-Add-driver-for-Sony-IMX477-sensor.patch
target/linux/bcm27xx/patches-5.10/950-0639-cgroup-Disable-cgroup-memory-by-default.patch
target/linux/bcm27xx/patches-5.10/950-0657-Documentation-devicetree-Add-documentation-for-imx37.patch
target/linux/bcm27xx/patches-5.10/950-0709-drm-Add-GUD-USB-Display-driver.patch
target/linux/generic/backport-5.10/601-v5.12-net-implement-threaded-able-napi-poll-loop-support.patch
target/linux/generic/backport-5.10/610-v5.13-11-net-resolve-forwarding-path-from-virtual-netdevice-a.patch
target/linux/generic/hack-5.10/280-rfkill-stubs.patch
target/linux/generic/hack-5.10/721-net-add-packet-mangeling.patch
target/linux/generic/hack-5.10/780-usb-net-MeigLink_modem_support.patch
target/linux/generic/pending-5.10/680-NET-skip-GRO-for-foreign-MAC-addresses.patch
target/linux/generic/pending-5.10/842-net-qmi_wwan-add-ZTE-MF286D-modem-19d2-1485.patch
target/linux/layerscape/patches-5.10/701-staging-add-fsl_ppfe-driver.patch
target/linux/mvebu/patches-5.10/907-MAINTAINERS-Add-an-entry-for-the-IEI-WT61P803-PUZZLE.patch
target/linux/ramips/patches-5.10/314-MIPS-add-bootargs-override-property.patch
target/linux/ramips/patches-5.10/315-owrt-hack-fix-mt7688-cache-issue.patch
target/linux/realtek/patches-5.10/008-5.17-watchdog-add-realtek-otto-watchdog-timer.patch
target/linux/uml/patches-5.10/001-um-Fix-build-w-o-CONFIG_PM_SLEEP.patch [deleted file]

index fd298a6a45f2927c9dc204d99f44b22f8bf13448..a7e1be4c3073a44b22f877203021942ea291ec47 100644 (file)
@@ -1,2 +1,2 @@
-LINUX_VERSION-5.10 = .184
-LINUX_KERNEL_HASH-5.10.184 = 77a9bebc1d1fa057212a3ac62c2a0784aafcdef149032df8898ebc9ed3c62908
+LINUX_VERSION-5.10 = .185
+LINUX_KERNEL_HASH-5.10.185 = 280662ec8dc8738cf947ad66e748141abd58cbe3b5ed66b7f2b153222b7c7090
index 9c659bab5964308a2cbc6ff79f9ec414549e43b3..eb43e6ac351dae979d359f3a05dd1ee299324b97 100644 (file)
        ptr = ip6hoff + sizeof(struct ipv6hdr);
 --- a/include/net/neighbour.h
 +++ b/include/net/neighbour.h
-@@ -275,8 +275,10 @@ static inline bool neigh_key_eq128(const
+@@ -270,8 +270,10 @@ static inline bool neigh_key_eq128(const
        const u32 *n32 = (const u32 *)n->primary_key;
        const u32 *p32 = pkey;
  
index 866c9c9bade14fcbb6c3922410c2f05576d6c83a..32835f709d3683d0c6921414c860faa3133a742d 100644 (file)
@@ -221,7 +221,7 @@ Signed-off-by: Yaroslav Rosomakho <yaroslavros@gmail.com>
  static inline int mmc_blk_part_switch(struct mmc_card *card,
                                      unsigned int part_type);
  static void mmc_blk_rw_rq_prep(struct mmc_queue_req *mqrq,
-@@ -2901,6 +2908,7 @@ static int mmc_blk_probe(struct mmc_card
+@@ -2906,6 +2913,7 @@ static int mmc_blk_probe(struct mmc_card
  {
        struct mmc_blk_data *md, *part_md;
        char cap_str[10];
@@ -229,7 +229,7 @@ Signed-off-by: Yaroslav Rosomakho <yaroslavros@gmail.com>
  
        /*
         * Check that the card supports the command class(es) we need.
-@@ -2908,7 +2916,16 @@ static int mmc_blk_probe(struct mmc_card
+@@ -2913,7 +2921,16 @@ static int mmc_blk_probe(struct mmc_card
        if (!(card->csd.cmdclass & CCC_BLOCK_READ))
                return -ENODEV;
  
@@ -247,7 +247,7 @@ Signed-off-by: Yaroslav Rosomakho <yaroslavros@gmail.com>
  
        card->complete_wq = alloc_workqueue("mmc_complete",
                                        WQ_MEM_RECLAIM | WQ_HIGHPRI, 0);
-@@ -2923,9 +2940,14 @@ static int mmc_blk_probe(struct mmc_card
+@@ -2928,9 +2945,14 @@ static int mmc_blk_probe(struct mmc_card
  
        string_get_size((u64)get_capacity(md->disk), 512, STRING_UNITS_2,
                        cap_str, sizeof(cap_str));
index 0ddd8ac352554f15b77d16dfe2edeade3ed0faeb..2b3c8a498cd0616235ea43eb411e83fc2685994a 100644 (file)
@@ -25,7 +25,7 @@ Signed-off-by: Naushir Patuck <naush@raspberrypi.com>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -16348,6 +16348,14 @@ S:    Maintained
+@@ -16341,6 +16341,14 @@ S:    Maintained
  T:    git git://linuxtv.org/media_tree.git
  F:    drivers/media/i2c/imx355.c
  
index 639dc9fe9b7d3e63aac0f1f360b0751415a5142b..41161b870e516632f638b180d5251d51681e5281 100644 (file)
@@ -40,7 +40,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
        for_each_subsys(ss, ssid) {
                if (ss->early_init) {
                        struct cgroup_subsys_state *css =
-@@ -6361,6 +6370,10 @@ static int __init cgroup_disable(char *s
+@@ -6360,6 +6369,10 @@ static int __init cgroup_disable(char *s
                            strcmp(token, ss->legacy_name))
                                continue;
  
@@ -51,7 +51,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.org>
                        static_branch_disable(cgroup_subsys_enabled_key[i]);
                        pr_info("Disabling %s control group subsystem\n",
                                ss->name);
-@@ -6370,6 +6383,31 @@ static int __init cgroup_disable(char *s
+@@ -6369,6 +6382,31 @@ static int __init cgroup_disable(char *s
  }
  __setup("cgroup_disable=", cgroup_disable);
  
index d4655751e0e1d01b44fa957cc00a51cf16f3c2f6..4eed812a203369011590d148ebaa54a06f73b9dd 100644 (file)
@@ -132,7 +132,7 @@ Signed-off-by: David Plowman <david.plowman@raspberrypi.com>
 +...
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -16362,6 +16362,7 @@ M:     Raspberry Pi Kernel Maintenance <kern
+@@ -16355,6 +16355,7 @@ M:     Raspberry Pi Kernel Maintenance <kern
  L:    linux-media@vger.kernel.org
  S:    Maintained
  T:    git git://linuxtv.org/media_tree.git
index f0380479d2f117d6a9b86e9b9e4d501a9ce0db33..286e61620f0d8ed6bb14d062f6036f14739419c0 100644 (file)
@@ -161,7 +161,7 @@ Signed-off-by: Noralf Trønnes <noralf@tronnes.org>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -5526,6 +5526,14 @@ S:      Maintained
+@@ -5519,6 +5519,14 @@ S:      Maintained
  F:    Documentation/devicetree/bindings/display/panel/feiyang,fy07024di26a30d.yaml
  F:    drivers/gpu/drm/panel/panel-feiyang-fy07024di26a30d.c
  
index a522ab952ea4f9bcf0f09609b0caa9062bc4bc43..529fd9260493a6f5d571111ccb1a7e6181922f91 100644 (file)
@@ -76,7 +76,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  
  /**
   *    napi_synchronize - wait until NAPI is not running
-@@ -1868,6 +1858,8 @@ enum netdev_ml_priv_type {
+@@ -1867,6 +1857,8 @@ enum netdev_ml_priv_type {
   *
   *    @wol_enabled:   Wake-on-LAN is enabled
   *
@@ -85,7 +85,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
   *    @net_notifier_list:     List of per-net netdev notifier block
   *                            that follow this device when it is moved
   *                            to another network namespace.
-@@ -2187,6 +2179,7 @@ struct net_device {
+@@ -2183,6 +2175,7 @@ struct net_device {
        struct lock_class_key   *qdisc_running_key;
        bool                    proto_down;
        unsigned                wol_enabled:1;
index 3b6e1b10cc206f4f6b969f340b876ed73163713a..1223e4965f61fc6133d0c3f949a7836c630e3b6b 100644 (file)
@@ -104,7 +104,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  };
  
  /**
-@@ -2854,6 +2879,8 @@ void dev_remove_offload(struct packet_of
+@@ -2850,6 +2875,8 @@ void dev_remove_offload(struct packet_of
  
  int dev_get_iflink(const struct net_device *dev);
  int dev_fill_metadata_dst(struct net_device *dev, struct sk_buff *skb);
index 2e48aea1cfb8c736db0cc510ed310b9c788d15c5..8715a1a5c60999d09cc59be23d03dfbaa189f239 100644 (file)
@@ -26,7 +26,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
   * @name: name of the struct -- the string is not copied internally
 --- a/net/Makefile
 +++ b/net/Makefile
-@@ -53,7 +53,7 @@ obj-$(CONFIG_TIPC)           += tipc/
+@@ -52,7 +52,7 @@ obj-$(CONFIG_TIPC)           += tipc/
  obj-$(CONFIG_NETLABEL)                += netlabel/
  obj-$(CONFIG_IUCV)            += iucv/
  obj-$(CONFIG_SMC)             += smc/
index 051246c3d65bb56ef9062ebd4b52d984288d4b97..e6e7bfc04558429f1dceee052c14d79b9a637149 100644 (file)
@@ -35,7 +35,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
  /* Specifies the type of the struct net_device::ml_priv pointer */
  enum netdev_ml_priv_type {
-@@ -2023,6 +2025,11 @@ struct net_device {
+@@ -2022,6 +2024,11 @@ struct net_device {
        const struct tlsdev_ops *tlsdev_ops;
  #endif
  
@@ -47,7 +47,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        const struct header_ops *header_ops;
  
        unsigned int            flags;
-@@ -2113,6 +2120,10 @@ struct net_device {
+@@ -2109,6 +2116,10 @@ struct net_device {
        struct mpls_dev __rcu   *mpls_ptr;
  #endif
  
index 21ddfc7a119c4692bff029510da518d75e137cdc..d92387ffe3b6bae6de20973ffe8d3d5afe114d92 100644 (file)
@@ -19,7 +19,7 @@
  
  #define QUECTEL_VENDOR_ID                     0x2c7c
  /* These Quectel products use Quectel's vendor ID */
-@@ -1169,6 +1171,11 @@ static const struct usb_device_id option
+@@ -1173,6 +1175,11 @@ static const struct usb_device_id option
          .driver_info = ZLP },
        { USB_DEVICE(QUECTEL_VENDOR_ID, QUECTEL_PRODUCT_BG96),
          .driver_info = RSVD(4) },
index 99eff273bdd2d85cf6fe6eb4643b53e689a0414d..d68dd08ed0598961a91ffcb333f53ee197aa7269 100644 (file)
@@ -11,7 +11,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
-@@ -2062,6 +2062,8 @@ struct net_device {
+@@ -2061,6 +2061,8 @@ struct net_device {
        struct netdev_hw_addr_list      mc;
        struct netdev_hw_addr_list      dev_addrs;
  
index c6f127add160d8b5dfa938898ca01e4236a10f9f..f91703431109d9ed5998110a68290bfe6c87c570 100644 (file)
@@ -49,7 +49,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/net/usb/qmi_wwan.c
 +++ b/drivers/net/usb/qmi_wwan.c
-@@ -1253,6 +1253,7 @@ static const struct usb_device_id produc
+@@ -1255,6 +1255,7 @@ static const struct usb_device_id produc
        {QMI_FIXED_INTF(0x19d2, 0x1426, 2)},    /* ZTE MF91 */
        {QMI_FIXED_INTF(0x19d2, 0x1428, 2)},    /* Telewell TW-LTE 4G v2 */
        {QMI_FIXED_INTF(0x19d2, 0x1432, 3)},    /* ZTE ME3620 */
index 71c86e55fd9a7d21fb24e3cd31f4fa167c87300b..6198fd8a4898ac7744391a05b30c76f2f47a64cd 100644 (file)
@@ -1090,7 +1090,7 @@ Date:   Wed Sep 30 17:20:19 2020 +0530
 +};
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -7068,6 +7068,14 @@ F:      drivers/ptp/ptp_qoriq.c
+@@ -7061,6 +7061,14 @@ F:      drivers/ptp/ptp_qoriq.c
  F:    drivers/ptp/ptp_qoriq_debugfs.c
  F:    include/linux/fsl/ptp_qoriq.h
  
index 577a9b40def5f80a4895abd0133ab667c8f8f380..a216b8c08b2443bf6e59771c26f41ff55960a73b 100644 (file)
@@ -16,7 +16,7 @@ Cc: Robert Marko <robert.marko@sartura.hr>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -8538,6 +8538,22 @@ F:      include/net/nl802154.h
+@@ -8531,6 +8531,22 @@ F:      include/net/nl802154.h
  F:    net/ieee802154/
  F:    net/mac802154/
  
index a5df046ba745a4251a4b8c9b18271fd1d353bd7a..2ea727b7078d3e620db512de582f7d41f3fe973f 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
 
 --- a/arch/mips/kernel/setup.c
 +++ b/arch/mips/kernel/setup.c
-@@ -542,8 +542,28 @@ static int __init bootcmdline_scan_chose
+@@ -543,8 +543,28 @@ static int __init bootcmdline_scan_chose
  
  #endif /* CONFIG_OF_EARLY_FLATTREE */
  
@@ -46,7 +46,7 @@ Signed-off-by: David Bauer <mail@david-bauer.net>
        bool dt_bootargs = false;
  
        /*
-@@ -557,6 +577,14 @@ static void __init bootcmdline_init(void
+@@ -558,6 +578,14 @@ static void __init bootcmdline_init(void
        }
  
        /*
index 59d4b3ce564fbfa2cb6f9b92a3f10aa6530d847e..85f3a3067fac5e83cb1e532f9f2b2f7ff6c60df3 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
 
 --- a/arch/mips/kernel/setup.c
 +++ b/arch/mips/kernel/setup.c
-@@ -694,8 +694,6 @@ static void __init arch_mem_init(char **
+@@ -695,8 +695,6 @@ static void __init arch_mem_init(char **
        if (crashk_res.start != crashk_res.end)
                memblock_reserve(crashk_res.start, resource_size(&crashk_res));
  #endif
@@ -19,7 +19,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
        /*
         * In order to reduce the possibility of kernel panic when failed to
         * get IO TLB memory under CONFIG_SWIOTLB, it is better to allocate
-@@ -815,6 +813,7 @@ void __init setup_arch(char **cmdline_p)
+@@ -816,6 +814,7 @@ void __init setup_arch(char **cmdline_p)
  
        cpu_cache_init();
        paging_init();
index 845441b4257fb6cd578e4e21939a2b15fc198ba2..2f58ec57424b2f07713deec21abe6868290f09f4 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: Guenter Roeck <linux@roeck-us.net>
 
 --- a/MAINTAINERS
 +++ b/MAINTAINERS
-@@ -14816,6 +14816,13 @@ S:    Maintained
+@@ -14809,6 +14809,13 @@ S:    Maintained
  F:    include/sound/rt*.h
  F:    sound/soc/codecs/rt*
  
diff --git a/target/linux/uml/patches-5.10/001-um-Fix-build-w-o-CONFIG_PM_SLEEP.patch b/target/linux/uml/patches-5.10/001-um-Fix-build-w-o-CONFIG_PM_SLEEP.patch
deleted file mode 100644 (file)
index acee358..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
-From 1fb1abc83636f5329c26cd29f0f19f3faeb697a5 Mon Sep 17 00:00:00 2001
-From: Johannes Berg <johannes.berg@intel.com>
-Date: Mon, 14 Dec 2020 20:51:02 +0100
-Subject: [PATCH] um: Fix build w/o CONFIG_PM_SLEEP
-
-uml_pm_wake() is unconditionally called from the SIGUSR1 wakeup
-handler since that's in the userspace portion of UML, and thus
-a bit tricky to ifdef out. Since pm_system_wakeup() can always
-be called (but may be an empty inline), also simply always have
-uml_pm_wake() to fix the build.
-
-Reported-by: Randy Dunlap <rdunlap@infradead.org>
-Acked-by: Randy Dunlap <rdunlap@infradead.org> # build-tested
-Signed-off-by: Johannes Berg <johannes.berg@intel.com>
-Signed-off-by: Richard Weinberger <richard@nod.at>
----
---- a/arch/um/kernel/um_arch.c
-+++ b/arch/um/kernel/um_arch.c
-@@ -387,12 +387,12 @@ void text_poke_sync(void)
- {
- }
--#ifdef CONFIG_PM_SLEEP
- void uml_pm_wake(void)
- {
-       pm_system_wakeup();
- }
-+#ifdef CONFIG_PM_SLEEP
- static int init_pm_wake_signal(void)
- {
-       /*