Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
--- a/net/rfkill/Makefile
+++ b/net/rfkill/Makefile
-@@ -2,6 +2,6 @@
+@@ -2,7 +2,7 @@
# Makefile for the RF switch subsystem.
#
+rfkill_backport-y += core.o
+rfkill_backport-$(CONFIG_RFKILL_BACKPORT_INPUT) += input.o
+obj-$(CONFIG_RFKILL_BACKPORT) += rfkill_backport.o
+ obj-$(CONFIG_RFKILL_REGULATOR) += rfkill-regulator.o
--- a/net/rfkill/input.c
+++ b/net/rfkill/input.c
@@ -232,7 +232,7 @@ static int rfkill_connect(struct input_h