projects
/
openwrt
/
staging
/
wigyori.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
73e912a
)
kernel/iio-bmp280: fix missing dependency
author
Mieczyslaw Nalewaj
<namiltd@yahoo.com>
Mon, 25 Nov 2024 14:56:18 +0000
(15:56 +0100)
committer
Zoltan HERPAI
<wigyori@uid0.hu>
Tue, 17 Dec 2024 22:28:11 +0000
(23:28 +0100)
Fix missing dependency on kernel 6.12.
Signed-off-by: Mieczyslaw Nalewaj <namiltd@yahoo.com>
package/kernel/linux/modules/iio.mk
patch
|
blob
|
history
diff --git
a/package/kernel/linux/modules/iio.mk
b/package/kernel/linux/modules/iio.mk
index e98a6830da0342e8b56bca8e772169a6124facbd..531c8207dbd141495e4b551f7adb7406509422d0 100644
(file)
--- a/
package/kernel/linux/modules/iio.mk
+++ b/
package/kernel/linux/modules/iio.mk
@@
-252,7
+252,7
@@
$(eval $(call KernelPackage,iio-bme680-spi))
define KernelPackage/iio-bmp280
TITLE:=BMP180/BMP280/BME280 pressure/temperatur sensor
- DEPENDS:=+kmod-regmap-core
+ DEPENDS:=+kmod-regmap-core
+LINUX_6_12:kmod-industrialio-triggered-buffer
KCONFIG:=CONFIG_BMP280
FILES:=$(LINUX_DIR)/drivers/iio/pressure/bmp280.ko
$(call AddDepends/iio)