update lzo, and openvpn to latest versions, fix vtun and tinc for lzo2
authorFelix Fietkau <nbd@openwrt.org>
Fri, 29 Sep 2006 19:11:03 +0000 (19:11 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 29 Sep 2006 19:11:03 +0000 (19:11 +0000)
SVN-Revision: 4875

openwrt/package/lzo/Makefile
openwrt/package/lzo/patches/lzo-cross-compile.patch [deleted file]
openwrt/package/openvpn/Makefile
openwrt/package/tinc/Makefile
openwrt/package/tinc/patches/100-lzo2.patch [new file with mode: 0644]

index b7e6324117ffcb19543b45e816843cf92110ecd1..5a7493c04003c0a15992fcd17e418617291fc5ff 100644 (file)
@@ -3,9 +3,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lzo
-PKG_VERSION:=1.08
+PKG_VERSION:=2.02
 PKG_RELEASE:=1
-PKG_MD5SUM:=ab94d3da364c7cbd5b78d76f1875b0f6
+PKG_MD5SUM:=6760e5819f4238328709bf93bf10071c
 
 PKG_SOURCE_URL:=http://www.oberhumer.com/opensource/lzo/download/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -60,23 +60,23 @@ $(PKG_BUILD_DIR)/.built:
 
 $(IPKG_LIBLZO):
        install -d -m0755 $(IDIR_LIBLZO)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblzo.so.* $(IDIR_LIBLZO)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblzo2.so.* $(IDIR_LIBLZO)/usr/lib
        $(RSTRIP) $(IDIR_LIBLZO)
        $(IPKG_BUILD) $(IDIR_LIBLZO) $(PACKAGE_DIR)
 
 $(STAGING_DIR)/usr/lib/liblzo.so: $(PKG_BUILD_DIR)/.built
        mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/lzo*.h $(STAGING_DIR)/usr/include/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/lzo $(STAGING_DIR)/usr/include/
        mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblzo.{a,so*} $(STAGING_DIR)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblzo2.{a,so*} $(STAGING_DIR)/usr/lib/
        touch $(STAGING_DIR)/usr/lib/liblzo.so
 
 install-dev: $(STAGING_DIR)/usr/lib/liblzo.so
 
 uninstall-dev:
        rm -rf \
-         $(STAGING_DIR)/usr/include/lzo*.h \
-         $(STAGING_DIR)/usr/lib/liblzo.{a,so*} \
+         $(STAGING_DIR)/usr/include/lzo* \
+         $(STAGING_DIR)/usr/lib/liblzo2.{a,so*} \
 
 compile: install-dev
 clean: uninstall-dev
diff --git a/openwrt/package/lzo/patches/lzo-cross-compile.patch b/openwrt/package/lzo/patches/lzo-cross-compile.patch
deleted file mode 100644 (file)
index 68a3d04..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-For some reason the lzo autoconf script uses a local macro that does
-a test for cross-compiles, and assumes that if the build target name
-and the host target name are the same that --host was not specified to
-the configure script. In the uClibc buildroot, this is not the case.
-
---- lzo-1.08/aclocal.m4        2002-07-12 18:31:52.000000000 -0700
-+++ lzo-1.08/aclocal.m4.new    2004-03-10 15:32:42.000000000 -0700
-@@ -205,12 +205,6 @@
- [
- AC_REQUIRE([AC_PROG_CC])
--if test "X$cross_compiling" = Xyes; then
--  if test "X$build" = "X$host"; then
--    AC_MSG_ERROR([you are cross compiling - please use the \`--host=' option])
--  fi
--fi
--
- ])
---- lzo-1.08/configure-dist    2004-03-11 02:18:28.000000000 -0600
-+++ lzo-1.08/configure 2004-03-11 02:19:16.000000000 -0600
-@@ -2282,13 +2282,13 @@
--if test "X$cross_compiling" = Xyes; then
--  if test "X$build" = "X$host"; then
--    { { echo "$as_me:$LINENO: error: you are cross compiling - please use the \`--host=' option" >&5
--echo "$as_me: error: you are cross compiling - please use the \`--host=' option" >&2;}
--   { (exit 1); exit 1; }; }
--  fi
--fi
-+#if test "X$cross_compiling" = Xyes; then
-+#  if test "X$build" = "X$host"; then
-+#    { { echo "$as_me:$LINENO: error: you are cross compiling - please use the \`--host=' option" >&5
-+#echo "$as_me: error: you are cross compiling - please use the \`--host=' option" >&2;}
-+#   { (exit 1); exit 1; }; }
-+#  fi
-+#fi
index 87b20e0add06434e4c8f2f139f9a6efa0e029cd9..2bab13b4f94e89b278095600ac0cfc3977f1046f 100644 (file)
@@ -3,9 +3,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openvpn
-PKG_VERSION:=2.0.7
+PKG_VERSION:=2.0.8
 PKG_RELEASE:=1
-PKG_MD5SUM:=93528233f1f6d02fc18e2c00f82e0aca
+PKG_MD5SUM:=de41592b6dd88d33b7c45c114a4f4e00
 
 PKG_SOURCE_URL:=http://openvpn.net/release @SF/openvpn
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
index e3f2d9465853886e27d05658076f11288b33f376..237ebde698433f4fc1889c258d02e4410ea05f2f 100644 (file)
@@ -48,6 +48,7 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
                  $(DISABLE_LARGEFILE) \
                  --with-kernel=$(LINUX_DIR) \
                  --with-zlib=$(STAGING_DIR)/usr/ \
+                 --with-lzo-include=$(STAGING_DIR)/usr/include/lzo \
        );
        touch $@
 
diff --git a/openwrt/package/tinc/patches/100-lzo2.patch b/openwrt/package/tinc/patches/100-lzo2.patch
new file mode 100644 (file)
index 0000000..a08374a
--- /dev/null
@@ -0,0 +1,73 @@
+diff -ru tinc-1.0.4.orig/configure tinc-1.0.4/configure
+--- tinc-1.0.4.orig/configure  2005-05-05 04:24:06.000000000 +1000
++++ tinc-1.0.4/configure       2005-11-13 18:34:21.000000000 +1100
+@@ -11074,13 +11144,13 @@
+ done
+-  echo "$as_me:$LINENO: checking for lzo1x_1_compress in -llzo" >&5
+-echo $ECHO_N "checking for lzo1x_1_compress in -llzo... $ECHO_C" >&6
+-if test "${ac_cv_lib_lzo_lzo1x_1_compress+set}" = set; then
++  echo "$as_me:$LINENO: checking for lzo1x_1_compress in -llzo2" >&5
++echo $ECHO_N "checking for lzo1x_1_compress in -llzo2... $ECHO_C" >&6
++if test "${ac_cv_lib_lzo2_lzo1x_1_compress+set}" = set; then
+   echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+   ac_check_lib_save_LIBS=$LIBS
+-LIBS="-llzo  $LIBS"
++LIBS="-llzo2  $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h.  */
+ _ACEOF
+@@ -11112,7 +11182,8 @@
+   cat conftest.err >&5
+   echo "$as_me:$LINENO: \$? = $ac_status" >&5
+   (exit $ac_status); } &&
+-       { ac_try='test -z "$ac_c_werror_flag"                   || test ! -s conftest.err'
++       { ac_try='test -z "$ac_c_werror_flag"
++                       || test ! -s conftest.err'
+   { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+   (eval $ac_try) 2>&5
+   ac_status=$?
+@@ -11124,21 +11195,21 @@
+   ac_status=$?
+   echo "$as_me:$LINENO: \$? = $ac_status" >&5
+   (exit $ac_status); }; }; then
+-  ac_cv_lib_lzo_lzo1x_1_compress=yes
++  ac_cv_lib_lzo2_lzo1x_1_compress=yes
+ else
+   echo "$as_me: failed program was:" >&5
+ sed 's/^/| /' conftest.$ac_ext >&5
+-ac_cv_lib_lzo_lzo1x_1_compress=no
++ac_cv_lib_lzo2_lzo1x_1_compress=no
+ fi
+ rm -f conftest.err conftest.$ac_objext \
+       conftest$ac_exeext conftest.$ac_ext
+ LIBS=$ac_check_lib_save_LIBS
+ fi
+-echo "$as_me:$LINENO: result: $ac_cv_lib_lzo_lzo1x_1_compress" >&5
+-echo "${ECHO_T}$ac_cv_lib_lzo_lzo1x_1_compress" >&6
+-if test $ac_cv_lib_lzo_lzo1x_1_compress = yes; then
+-  LIBS="$LIBS -llzo"
++echo "$as_me:$LINENO: result: $ac_cv_lib_lzo2_lzo1x_1_compress" >&5
++echo "${ECHO_T}$ac_cv_lib_lzo2_lzo1x_1_compress" >&6
++if test $ac_cv_lib_lzo2_lzo1x_1_compress = yes; then
++  LIBS="$LIBS -llzo2"
+ else
+   { { echo "$as_me:$LINENO: error: \"lzo libraries not found.\"" >&5
+ echo "$as_me: error: \"lzo libraries not found.\"" >&2;}
+diff -ru tinc-1.0.4.orig/m4/lzo.m4 tinc-1.0.4/m4/lzo.m4
+--- tinc-1.0.4.orig/m4/lzo.m4  2004-03-25 08:04:27.000000000 +1100
++++ tinc-1.0.4/m4/lzo.m4       2005-11-13 18:38:39.000000000 +1100
+@@ -26,8 +26,8 @@
+     [AC_MSG_ERROR("lzo header files not found."); break]
+   )
+-  AC_CHECK_LIB(lzo, lzo1x_1_compress,
+-    [LIBS="$LIBS -llzo"],
++  AC_CHECK_LIB(lzo2, lzo1x_1_compress,
++    [LIBS="$LIBS -llzo2"],
+     [AC_MSG_ERROR("lzo libraries not found.")]
+   )
+ ])