projects
/
openwrt
/
staging
/
chunkeey.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
d2d990e
)
gcc: fix newer libstdc++ compile issues with uclibc 0.9.32
author
Felix Fietkau
<nbd@openwrt.org>
Mon, 20 Dec 2010 14:25:05 +0000
(14:25 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Mon, 20 Dec 2010 14:25:05 +0000
(14:25 +0000)
SVN-Revision: 24734
toolchain/gcc/common.mk
patch
|
blob
|
history
diff --git
a/toolchain/gcc/common.mk
b/toolchain/gcc/common.mk
index ebc5c1e6db068bd62e9d287f93e83962b2508bc7..3a4a94a46afebfdbaacbbfbe0832cbaf1f5ab0c4 100644
(file)
--- a/
toolchain/gcc/common.mk
+++ b/
toolchain/gcc/common.mk
@@
-95,6
+95,9
@@
SEP:=,
TARGET_LANGUAGES:="c$(if $(CONFIG_INSTALL_LIBSTDCPP),$(SEP)c++)$(if $(CONFIG_INSTALL_LIBGCJ),$(SEP)java)"
export libgcc_cv_fixed_point=no
+ifdef CONFIG_USE_UCLIBC
+ export glibcxx_cv_c99_math_tr1=no
+endif
GCC_CONFIGURE:= \
SHELL="$(BASH)" \