MIPS: ralink: Move device-trees to arch/mips/boot/dts/
authorAndrew Bresticker <abrestic@chromium.org>
Thu, 21 Aug 2014 20:04:26 +0000 (13:04 -0700)
committerRalf Baechle <ralf@linux-mips.org>
Mon, 22 Sep 2014 11:35:50 +0000 (13:35 +0200)
Move the Ralink device-trees to arch/mips/boot/dts/ and update the
Makefiles accordingly.  A built-in device-tree is optional, so select
BUILTIN_DTB when it is requested.

Signed-off-by: Andrew Bresticker <abrestic@chromium.org>
Cc: Rob Herring <robh+dt@kernel.org>
Cc: Pawel Moll <pawel.moll@arm.com>
Cc: Mark Rutland <mark.rutland@arm.com>
Cc: Ian Campbell <ijc+devicetree@hellion.org.uk>
Cc: Kumar Gala <galak@codeaurora.org>
Cc: James Hogan <james.hogan@imgtec.com>
Cc: Paul Burton <paul.burton@imgtec.com>
Cc: David Daney <david.daney@cavium.com>
Cc: John Crispin <blogic@openwrt.org>
Cc: Jayachandran C <jchandra@broadcom.com>
Cc: Qais Yousef <qais.yousef@imgtec.com>
Cc: linux-mips@linux-mips.org
Cc: linux-kernel@vger.kernel.org
Cc: devicetree@vger.kernel.org
Patchwork: https://patchwork.linux-mips.org/patch/7561/
Signed-off-by: Ralf Baechle <ralf@linux-mips.org>
20 files changed:
arch/mips/boot/dts/Makefile
arch/mips/boot/dts/mt7620a.dtsi [new file with mode: 0644]
arch/mips/boot/dts/mt7620a_eval.dts [new file with mode: 0644]
arch/mips/boot/dts/rt2880.dtsi [new file with mode: 0644]
arch/mips/boot/dts/rt2880_eval.dts [new file with mode: 0644]
arch/mips/boot/dts/rt3050.dtsi [new file with mode: 0644]
arch/mips/boot/dts/rt3052_eval.dts [new file with mode: 0644]
arch/mips/boot/dts/rt3883.dtsi [new file with mode: 0644]
arch/mips/boot/dts/rt3883_eval.dts [new file with mode: 0644]
arch/mips/ralink/Kconfig
arch/mips/ralink/Makefile
arch/mips/ralink/dts/Makefile [deleted file]
arch/mips/ralink/dts/mt7620a.dtsi [deleted file]
arch/mips/ralink/dts/mt7620a_eval.dts [deleted file]
arch/mips/ralink/dts/rt2880.dtsi [deleted file]
arch/mips/ralink/dts/rt2880_eval.dts [deleted file]
arch/mips/ralink/dts/rt3050.dtsi [deleted file]
arch/mips/ralink/dts/rt3052_eval.dts [deleted file]
arch/mips/ralink/dts/rt3883.dtsi [deleted file]
arch/mips/ralink/dts/rt3883_eval.dts [deleted file]

index 1638a3837caad86fdcf1a631a814e17101da0515..ca9c90e2cabf0cef63ed5e7025e6e42f52552167 100644 (file)
@@ -4,6 +4,10 @@ dtb-$(CONFIG_DT_XLP_EVP)               += xlp_evp.dtb
 dtb-$(CONFIG_DT_XLP_SVP)               += xlp_svp.dtb
 dtb-$(CONFIG_DT_XLP_FVP)               += xlp_fvp.dtb
 dtb-$(CONFIG_DT_XLP_GVP)               += xlp_gvp.dtb
+dtb-$(CONFIG_DTB_RT2880_EVAL)          += rt2880_eval.dtb
+dtb-$(CONFIG_DTB_RT305X_EVAL)          += rt3052_eval.dtb
+dtb-$(CONFIG_DTB_RT3883_EVAL)          += rt3883_eval.dtb
+dtb-$(CONFIG_DTB_MT7620A_EVAL)         += mt7620a_eval.dtb
 dtb-$(CONFIG_MIPS_SEAD3)               += sead3.dtb
 
 obj-y          += $(patsubst %.dtb, %.dtb.o, $(dtb-y))
diff --git a/arch/mips/boot/dts/mt7620a.dtsi b/arch/mips/boot/dts/mt7620a.dtsi
new file mode 100644 (file)
index 0000000..08bf24f
--- /dev/null
@@ -0,0 +1,58 @@
+/ {
+       #address-cells = <1>;
+       #size-cells = <1>;
+       compatible = "ralink,mtk7620a-soc";
+
+       cpus {
+               cpu@0 {
+                       compatible = "mips,mips24KEc";
+               };
+       };
+
+       cpuintc: cpuintc@0 {
+               #address-cells = <0>;
+               #interrupt-cells = <1>;
+               interrupt-controller;
+               compatible = "mti,cpu-interrupt-controller";
+       };
+
+       palmbus@10000000 {
+               compatible = "palmbus";
+               reg = <0x10000000 0x200000>;
+                ranges = <0x0 0x10000000 0x1FFFFF>;
+
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               sysc@0 {
+                       compatible = "ralink,mt7620a-sysc";
+                       reg = <0x0 0x100>;
+               };
+
+               intc: intc@200 {
+                       compatible = "ralink,mt7620a-intc", "ralink,rt2880-intc";
+                       reg = <0x200 0x100>;
+
+                       interrupt-controller;
+                       #interrupt-cells = <1>;
+
+                       interrupt-parent = <&cpuintc>;
+                       interrupts = <2>;
+               };
+
+               memc@300 {
+                       compatible = "ralink,mt7620a-memc", "ralink,rt3050-memc";
+                       reg = <0x300 0x100>;
+               };
+
+               uartlite@c00 {
+                       compatible = "ralink,mt7620a-uart", "ralink,rt2880-uart", "ns16550a";
+                       reg = <0xc00 0x100>;
+
+                       interrupt-parent = <&intc>;
+                       interrupts = <12>;
+
+                       reg-shift = <2>;
+               };
+       };
+};
diff --git a/arch/mips/boot/dts/mt7620a_eval.dts b/arch/mips/boot/dts/mt7620a_eval.dts
new file mode 100644 (file)
index 0000000..709f581
--- /dev/null
@@ -0,0 +1,17 @@
+/dts-v1/;
+
+/include/ "mt7620a.dtsi"
+
+/ {
+       compatible = "ralink,mt7620a-eval-board", "ralink,mt7620a-soc";
+       model = "Ralink MT7620A evaluation board";
+
+       memory@0 {
+               device_type = "memory";
+               reg = <0x0 0x2000000>;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,57600";
+       };
+};
diff --git a/arch/mips/boot/dts/rt2880.dtsi b/arch/mips/boot/dts/rt2880.dtsi
new file mode 100644 (file)
index 0000000..182afde
--- /dev/null
@@ -0,0 +1,58 @@
+/ {
+       #address-cells = <1>;
+       #size-cells = <1>;
+       compatible = "ralink,rt2880-soc";
+
+       cpus {
+               cpu@0 {
+                       compatible = "mips,mips4KEc";
+               };
+       };
+
+       cpuintc: cpuintc@0 {
+               #address-cells = <0>;
+               #interrupt-cells = <1>;
+               interrupt-controller;
+               compatible = "mti,cpu-interrupt-controller";
+       };
+
+       palmbus@300000 {
+               compatible = "palmbus";
+               reg = <0x300000 0x200000>;
+                ranges = <0x0 0x300000 0x1FFFFF>;
+
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               sysc@0 {
+                       compatible = "ralink,rt2880-sysc";
+                       reg = <0x0 0x100>;
+               };
+
+               intc: intc@200 {
+                       compatible = "ralink,rt2880-intc";
+                       reg = <0x200 0x100>;
+
+                       interrupt-controller;
+                       #interrupt-cells = <1>;
+
+                       interrupt-parent = <&cpuintc>;
+                       interrupts = <2>;
+               };
+
+               memc@300 {
+                       compatible = "ralink,rt2880-memc";
+                       reg = <0x300 0x100>;
+               };
+
+               uartlite@c00 {
+                       compatible = "ralink,rt2880-uart", "ns16550a";
+                       reg = <0xc00 0x100>;
+
+                       interrupt-parent = <&intc>;
+                       interrupts = <8>;
+
+                       reg-shift = <2>;
+               };
+       };
+};
diff --git a/arch/mips/boot/dts/rt2880_eval.dts b/arch/mips/boot/dts/rt2880_eval.dts
new file mode 100644 (file)
index 0000000..0a685db
--- /dev/null
@@ -0,0 +1,47 @@
+/dts-v1/;
+
+/include/ "rt2880.dtsi"
+
+/ {
+       compatible = "ralink,rt2880-eval-board", "ralink,rt2880-soc";
+       model = "Ralink RT2880 evaluation board";
+
+       memory@0 {
+               device_type = "memory";
+               reg = <0x8000000 0x2000000>;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,57600";
+       };
+
+       cfi@1f000000 {
+               compatible = "cfi-flash";
+               reg = <0x1f000000 0x400000>;
+
+               bank-width = <2>;
+               device-width = <2>;
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               partition@0 {
+                       label = "uboot";
+                       reg = <0x0 0x30000>;
+                       read-only;
+               };
+               partition@30000 {
+                       label = "uboot-env";
+                       reg = <0x30000 0x10000>;
+                       read-only;
+               };
+               partition@40000 {
+                       label = "calibration";
+                       reg = <0x40000 0x10000>;
+                       read-only;
+               };
+               partition@50000 {
+                       label = "linux";
+                       reg = <0x50000 0x3b0000>;
+               };
+       };
+};
diff --git a/arch/mips/boot/dts/rt3050.dtsi b/arch/mips/boot/dts/rt3050.dtsi
new file mode 100644 (file)
index 0000000..e3203d4
--- /dev/null
@@ -0,0 +1,68 @@
+/ {
+       #address-cells = <1>;
+       #size-cells = <1>;
+       compatible = "ralink,rt3050-soc", "ralink,rt3052-soc", "ralink,rt3350-soc";
+
+       cpus {
+               cpu@0 {
+                       compatible = "mips,mips24KEc";
+               };
+       };
+
+       cpuintc: cpuintc@0 {
+               #address-cells = <0>;
+               #interrupt-cells = <1>;
+               interrupt-controller;
+               compatible = "mti,cpu-interrupt-controller";
+       };
+
+       palmbus@10000000 {
+               compatible = "palmbus";
+               reg = <0x10000000 0x200000>;
+               ranges = <0x0 0x10000000 0x1FFFFF>;
+
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               sysc@0 {
+                       compatible = "ralink,rt3052-sysc", "ralink,rt3050-sysc";
+                       reg = <0x0 0x100>;
+               };
+
+               intc: intc@200 {
+                       compatible = "ralink,rt3052-intc", "ralink,rt2880-intc";
+                       reg = <0x200 0x100>;
+
+                       interrupt-controller;
+                       #interrupt-cells = <1>;
+
+                       interrupt-parent = <&cpuintc>;
+                       interrupts = <2>;
+               };
+
+               memc@300 {
+                       compatible = "ralink,rt3052-memc", "ralink,rt3050-memc";
+                       reg = <0x300 0x100>;
+               };
+
+               uartlite@c00 {
+                       compatible = "ralink,rt3052-uart", "ralink,rt2880-uart", "ns16550a";
+                       reg = <0xc00 0x100>;
+
+                       interrupt-parent = <&intc>;
+                       interrupts = <12>;
+
+                       reg-shift = <2>;
+               };
+       };
+
+       usb@101c0000 {
+               compatible = "ralink,rt3050-usb", "snps,dwc2";
+               reg = <0x101c0000 40000>;
+
+               interrupt-parent = <&intc>;
+               interrupts = <18>;
+
+               status = "disabled";
+       };
+};
diff --git a/arch/mips/boot/dts/rt3052_eval.dts b/arch/mips/boot/dts/rt3052_eval.dts
new file mode 100644 (file)
index 0000000..ec9e9a0
--- /dev/null
@@ -0,0 +1,51 @@
+/dts-v1/;
+
+#include "rt3050.dtsi"
+
+/ {
+       compatible = "ralink,rt3052-eval-board", "ralink,rt3052-soc";
+       model = "Ralink RT3052 evaluation board";
+
+       memory@0 {
+               device_type = "memory";
+               reg = <0x0 0x2000000>;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,57600";
+       };
+
+       cfi@1f000000 {
+               compatible = "cfi-flash";
+               reg = <0x1f000000 0x800000>;
+
+               bank-width = <2>;
+               device-width = <2>;
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               partition@0 {
+                       label = "uboot";
+                       reg = <0x0 0x30000>;
+                       read-only;
+               };
+               partition@30000 {
+                       label = "uboot-env";
+                       reg = <0x30000 0x10000>;
+                       read-only;
+               };
+               partition@40000 {
+                       label = "calibration";
+                       reg = <0x40000 0x10000>;
+                       read-only;
+               };
+               partition@50000 {
+                       label = "linux";
+                       reg = <0x50000 0x7b0000>;
+               };
+       };
+
+       usb@101c0000 {
+               status = "ok";
+       };
+};
diff --git a/arch/mips/boot/dts/rt3883.dtsi b/arch/mips/boot/dts/rt3883.dtsi
new file mode 100644 (file)
index 0000000..3b131dd
--- /dev/null
@@ -0,0 +1,58 @@
+/ {
+       #address-cells = <1>;
+       #size-cells = <1>;
+       compatible = "ralink,rt3883-soc";
+
+       cpus {
+               cpu@0 {
+                       compatible = "mips,mips74Kc";
+               };
+       };
+
+       cpuintc: cpuintc@0 {
+               #address-cells = <0>;
+               #interrupt-cells = <1>;
+               interrupt-controller;
+               compatible = "mti,cpu-interrupt-controller";
+       };
+
+       palmbus@10000000 {
+               compatible = "palmbus";
+               reg = <0x10000000 0x200000>;
+               ranges = <0x0 0x10000000 0x1FFFFF>;
+
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               sysc@0 {
+                       compatible = "ralink,rt3883-sysc", "ralink,rt3050-sysc";
+                       reg = <0x0 0x100>;
+               };
+
+               intc: intc@200 {
+                       compatible = "ralink,rt3883-intc", "ralink,rt2880-intc";
+                       reg = <0x200 0x100>;
+
+                       interrupt-controller;
+                       #interrupt-cells = <1>;
+
+                       interrupt-parent = <&cpuintc>;
+                       interrupts = <2>;
+               };
+
+               memc@300 {
+                       compatible = "ralink,rt3883-memc", "ralink,rt3050-memc";
+                       reg = <0x300 0x100>;
+               };
+
+               uartlite@c00 {
+                       compatible = "ralink,rt3883-uart", "ralink,rt2880-uart", "ns16550a";
+                       reg = <0xc00 0x100>;
+
+                       interrupt-parent = <&intc>;
+                       interrupts = <12>;
+
+                       reg-shift = <2>;
+               };
+       };
+};
diff --git a/arch/mips/boot/dts/rt3883_eval.dts b/arch/mips/boot/dts/rt3883_eval.dts
new file mode 100644 (file)
index 0000000..e8df21a
--- /dev/null
@@ -0,0 +1,17 @@
+/dts-v1/;
+
+/include/ "rt3883.dtsi"
+
+/ {
+       compatible = "ralink,rt3883-eval-board", "ralink,rt3883-soc";
+       model = "Ralink RT3883 evaluation board";
+
+       memory@0 {
+               device_type = "memory";
+               reg = <0x0 0x2000000>;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,57600";
+       };
+};
index 4a296655f4469391b17449fe3642c1d142308cc0..77e8a9620e183023bd67467ee8b8a1e468428220 100644 (file)
@@ -42,18 +42,22 @@ choice
        config DTB_RT2880_EVAL
                bool "RT2880 eval kit"
                depends on SOC_RT288X
+               select BUILTIN_DTB
 
        config DTB_RT305X_EVAL
                bool "RT305x eval kit"
                depends on SOC_RT305X
+               select BUILTIN_DTB
 
        config DTB_RT3883_EVAL
                bool "RT3883 eval kit"
                depends on SOC_RT3883
+               select BUILTIN_DTB
 
        config DTB_MT7620A_EVAL
                bool "MT7620A eval kit"
                depends on SOC_MT7620
+               select BUILTIN_DTB
 
 endchoice
 
index 98ae349827be8068943e16db9e851cbfd1cc4501..2c09c8aa0ae24e05ab18fa9721f6a70865bceb92 100644 (file)
@@ -16,5 +16,3 @@ obj-$(CONFIG_SOC_RT3883) += rt3883.o
 obj-$(CONFIG_SOC_MT7620) += mt7620.o
 
 obj-$(CONFIG_EARLY_PRINTK) += early_printk.o
-
-obj-y += dts/
diff --git a/arch/mips/ralink/dts/Makefile b/arch/mips/ralink/dts/Makefile
deleted file mode 100644 (file)
index 18194fa..0000000
+++ /dev/null
@@ -1,4 +0,0 @@
-obj-$(CONFIG_DTB_RT2880_EVAL) := rt2880_eval.dtb.o
-obj-$(CONFIG_DTB_RT305X_EVAL) := rt3052_eval.dtb.o
-obj-$(CONFIG_DTB_RT3883_EVAL) := rt3883_eval.dtb.o
-obj-$(CONFIG_DTB_MT7620A_EVAL) := mt7620a_eval.dtb.o
diff --git a/arch/mips/ralink/dts/mt7620a.dtsi b/arch/mips/ralink/dts/mt7620a.dtsi
deleted file mode 100644 (file)
index 08bf24f..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
-/ {
-       #address-cells = <1>;
-       #size-cells = <1>;
-       compatible = "ralink,mtk7620a-soc";
-
-       cpus {
-               cpu@0 {
-                       compatible = "mips,mips24KEc";
-               };
-       };
-
-       cpuintc: cpuintc@0 {
-               #address-cells = <0>;
-               #interrupt-cells = <1>;
-               interrupt-controller;
-               compatible = "mti,cpu-interrupt-controller";
-       };
-
-       palmbus@10000000 {
-               compatible = "palmbus";
-               reg = <0x10000000 0x200000>;
-                ranges = <0x0 0x10000000 0x1FFFFF>;
-
-               #address-cells = <1>;
-               #size-cells = <1>;
-
-               sysc@0 {
-                       compatible = "ralink,mt7620a-sysc";
-                       reg = <0x0 0x100>;
-               };
-
-               intc: intc@200 {
-                       compatible = "ralink,mt7620a-intc", "ralink,rt2880-intc";
-                       reg = <0x200 0x100>;
-
-                       interrupt-controller;
-                       #interrupt-cells = <1>;
-
-                       interrupt-parent = <&cpuintc>;
-                       interrupts = <2>;
-               };
-
-               memc@300 {
-                       compatible = "ralink,mt7620a-memc", "ralink,rt3050-memc";
-                       reg = <0x300 0x100>;
-               };
-
-               uartlite@c00 {
-                       compatible = "ralink,mt7620a-uart", "ralink,rt2880-uart", "ns16550a";
-                       reg = <0xc00 0x100>;
-
-                       interrupt-parent = <&intc>;
-                       interrupts = <12>;
-
-                       reg-shift = <2>;
-               };
-       };
-};
diff --git a/arch/mips/ralink/dts/mt7620a_eval.dts b/arch/mips/ralink/dts/mt7620a_eval.dts
deleted file mode 100644 (file)
index 709f581..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-/dts-v1/;
-
-/include/ "mt7620a.dtsi"
-
-/ {
-       compatible = "ralink,mt7620a-eval-board", "ralink,mt7620a-soc";
-       model = "Ralink MT7620A evaluation board";
-
-       memory@0 {
-               device_type = "memory";
-               reg = <0x0 0x2000000>;
-       };
-
-       chosen {
-               bootargs = "console=ttyS0,57600";
-       };
-};
diff --git a/arch/mips/ralink/dts/rt2880.dtsi b/arch/mips/ralink/dts/rt2880.dtsi
deleted file mode 100644 (file)
index 182afde..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
-/ {
-       #address-cells = <1>;
-       #size-cells = <1>;
-       compatible = "ralink,rt2880-soc";
-
-       cpus {
-               cpu@0 {
-                       compatible = "mips,mips4KEc";
-               };
-       };
-
-       cpuintc: cpuintc@0 {
-               #address-cells = <0>;
-               #interrupt-cells = <1>;
-               interrupt-controller;
-               compatible = "mti,cpu-interrupt-controller";
-       };
-
-       palmbus@300000 {
-               compatible = "palmbus";
-               reg = <0x300000 0x200000>;
-                ranges = <0x0 0x300000 0x1FFFFF>;
-
-               #address-cells = <1>;
-               #size-cells = <1>;
-
-               sysc@0 {
-                       compatible = "ralink,rt2880-sysc";
-                       reg = <0x0 0x100>;
-               };
-
-               intc: intc@200 {
-                       compatible = "ralink,rt2880-intc";
-                       reg = <0x200 0x100>;
-
-                       interrupt-controller;
-                       #interrupt-cells = <1>;
-
-                       interrupt-parent = <&cpuintc>;
-                       interrupts = <2>;
-               };
-
-               memc@300 {
-                       compatible = "ralink,rt2880-memc";
-                       reg = <0x300 0x100>;
-               };
-
-               uartlite@c00 {
-                       compatible = "ralink,rt2880-uart", "ns16550a";
-                       reg = <0xc00 0x100>;
-
-                       interrupt-parent = <&intc>;
-                       interrupts = <8>;
-
-                       reg-shift = <2>;
-               };
-       };
-};
diff --git a/arch/mips/ralink/dts/rt2880_eval.dts b/arch/mips/ralink/dts/rt2880_eval.dts
deleted file mode 100644 (file)
index 0a685db..0000000
+++ /dev/null
@@ -1,47 +0,0 @@
-/dts-v1/;
-
-/include/ "rt2880.dtsi"
-
-/ {
-       compatible = "ralink,rt2880-eval-board", "ralink,rt2880-soc";
-       model = "Ralink RT2880 evaluation board";
-
-       memory@0 {
-               device_type = "memory";
-               reg = <0x8000000 0x2000000>;
-       };
-
-       chosen {
-               bootargs = "console=ttyS0,57600";
-       };
-
-       cfi@1f000000 {
-               compatible = "cfi-flash";
-               reg = <0x1f000000 0x400000>;
-
-               bank-width = <2>;
-               device-width = <2>;
-               #address-cells = <1>;
-               #size-cells = <1>;
-
-               partition@0 {
-                       label = "uboot";
-                       reg = <0x0 0x30000>;
-                       read-only;
-               };
-               partition@30000 {
-                       label = "uboot-env";
-                       reg = <0x30000 0x10000>;
-                       read-only;
-               };
-               partition@40000 {
-                       label = "calibration";
-                       reg = <0x40000 0x10000>;
-                       read-only;
-               };
-               partition@50000 {
-                       label = "linux";
-                       reg = <0x50000 0x3b0000>;
-               };
-       };
-};
diff --git a/arch/mips/ralink/dts/rt3050.dtsi b/arch/mips/ralink/dts/rt3050.dtsi
deleted file mode 100644 (file)
index e3203d4..0000000
+++ /dev/null
@@ -1,68 +0,0 @@
-/ {
-       #address-cells = <1>;
-       #size-cells = <1>;
-       compatible = "ralink,rt3050-soc", "ralink,rt3052-soc", "ralink,rt3350-soc";
-
-       cpus {
-               cpu@0 {
-                       compatible = "mips,mips24KEc";
-               };
-       };
-
-       cpuintc: cpuintc@0 {
-               #address-cells = <0>;
-               #interrupt-cells = <1>;
-               interrupt-controller;
-               compatible = "mti,cpu-interrupt-controller";
-       };
-
-       palmbus@10000000 {
-               compatible = "palmbus";
-               reg = <0x10000000 0x200000>;
-               ranges = <0x0 0x10000000 0x1FFFFF>;
-
-               #address-cells = <1>;
-               #size-cells = <1>;
-
-               sysc@0 {
-                       compatible = "ralink,rt3052-sysc", "ralink,rt3050-sysc";
-                       reg = <0x0 0x100>;
-               };
-
-               intc: intc@200 {
-                       compatible = "ralink,rt3052-intc", "ralink,rt2880-intc";
-                       reg = <0x200 0x100>;
-
-                       interrupt-controller;
-                       #interrupt-cells = <1>;
-
-                       interrupt-parent = <&cpuintc>;
-                       interrupts = <2>;
-               };
-
-               memc@300 {
-                       compatible = "ralink,rt3052-memc", "ralink,rt3050-memc";
-                       reg = <0x300 0x100>;
-               };
-
-               uartlite@c00 {
-                       compatible = "ralink,rt3052-uart", "ralink,rt2880-uart", "ns16550a";
-                       reg = <0xc00 0x100>;
-
-                       interrupt-parent = <&intc>;
-                       interrupts = <12>;
-
-                       reg-shift = <2>;
-               };
-       };
-
-       usb@101c0000 {
-               compatible = "ralink,rt3050-usb", "snps,dwc2";
-               reg = <0x101c0000 40000>;
-
-               interrupt-parent = <&intc>;
-               interrupts = <18>;
-
-               status = "disabled";
-       };
-};
diff --git a/arch/mips/ralink/dts/rt3052_eval.dts b/arch/mips/ralink/dts/rt3052_eval.dts
deleted file mode 100644 (file)
index ec9e9a0..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-/dts-v1/;
-
-#include "rt3050.dtsi"
-
-/ {
-       compatible = "ralink,rt3052-eval-board", "ralink,rt3052-soc";
-       model = "Ralink RT3052 evaluation board";
-
-       memory@0 {
-               device_type = "memory";
-               reg = <0x0 0x2000000>;
-       };
-
-       chosen {
-               bootargs = "console=ttyS0,57600";
-       };
-
-       cfi@1f000000 {
-               compatible = "cfi-flash";
-               reg = <0x1f000000 0x800000>;
-
-               bank-width = <2>;
-               device-width = <2>;
-               #address-cells = <1>;
-               #size-cells = <1>;
-
-               partition@0 {
-                       label = "uboot";
-                       reg = <0x0 0x30000>;
-                       read-only;
-               };
-               partition@30000 {
-                       label = "uboot-env";
-                       reg = <0x30000 0x10000>;
-                       read-only;
-               };
-               partition@40000 {
-                       label = "calibration";
-                       reg = <0x40000 0x10000>;
-                       read-only;
-               };
-               partition@50000 {
-                       label = "linux";
-                       reg = <0x50000 0x7b0000>;
-               };
-       };
-
-       usb@101c0000 {
-               status = "ok";
-       };
-};
diff --git a/arch/mips/ralink/dts/rt3883.dtsi b/arch/mips/ralink/dts/rt3883.dtsi
deleted file mode 100644 (file)
index 3b131dd..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
-/ {
-       #address-cells = <1>;
-       #size-cells = <1>;
-       compatible = "ralink,rt3883-soc";
-
-       cpus {
-               cpu@0 {
-                       compatible = "mips,mips74Kc";
-               };
-       };
-
-       cpuintc: cpuintc@0 {
-               #address-cells = <0>;
-               #interrupt-cells = <1>;
-               interrupt-controller;
-               compatible = "mti,cpu-interrupt-controller";
-       };
-
-       palmbus@10000000 {
-               compatible = "palmbus";
-               reg = <0x10000000 0x200000>;
-               ranges = <0x0 0x10000000 0x1FFFFF>;
-
-               #address-cells = <1>;
-               #size-cells = <1>;
-
-               sysc@0 {
-                       compatible = "ralink,rt3883-sysc", "ralink,rt3050-sysc";
-                       reg = <0x0 0x100>;
-               };
-
-               intc: intc@200 {
-                       compatible = "ralink,rt3883-intc", "ralink,rt2880-intc";
-                       reg = <0x200 0x100>;
-
-                       interrupt-controller;
-                       #interrupt-cells = <1>;
-
-                       interrupt-parent = <&cpuintc>;
-                       interrupts = <2>;
-               };
-
-               memc@300 {
-                       compatible = "ralink,rt3883-memc", "ralink,rt3050-memc";
-                       reg = <0x300 0x100>;
-               };
-
-               uartlite@c00 {
-                       compatible = "ralink,rt3883-uart", "ralink,rt2880-uart", "ns16550a";
-                       reg = <0xc00 0x100>;
-
-                       interrupt-parent = <&intc>;
-                       interrupts = <12>;
-
-                       reg-shift = <2>;
-               };
-       };
-};
diff --git a/arch/mips/ralink/dts/rt3883_eval.dts b/arch/mips/ralink/dts/rt3883_eval.dts
deleted file mode 100644 (file)
index e8df21a..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-/dts-v1/;
-
-/include/ "rt3883.dtsi"
-
-/ {
-       compatible = "ralink,rt3883-eval-board", "ralink,rt3883-soc";
-       model = "Ralink RT3883 evaluation board";
-
-       memory@0 {
-               device_type = "memory";
-               reg = <0x0 0x2000000>;
-       };
-
-       chosen {
-               bootargs = "console=ttyS0,57600";
-       };
-};