projects
/
openwrt
/
staging
/
thess.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
2ba3e0e
)
build: remove check for nonexistant CONFIG_TAR_VERBOSITY variable and move TAR_OPTION...
author
Felix Fietkau
<nbd@openwrt.org>
Fri, 21 Mar 2014 15:54:03 +0000
(15:54 +0000)
committer
Felix Fietkau
<nbd@openwrt.org>
Fri, 21 Mar 2014 15:54:03 +0000
(15:54 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 39979
include/unpack.mk
patch
|
blob
|
history
rules.mk
patch
|
blob
|
history
diff --git
a/include/unpack.mk
b/include/unpack.mk
index 2d3586309516ae83f28d1d3a78e8e25e773b5993..2b33c4cd8ea214b767d33e0f2c22b3adb38dc6f1 100644
(file)
--- a/
include/unpack.mk
+++ b/
include/unpack.mk
@@
-11,6
+11,8
@@
ifneq ($(HOST_OS),Linux)
else
HOST_TAR:=$(TAR)
endif
+
+TAR_OPTIONS:=-xf -
TAR_CMD=$(HOST_TAR) -C $(1)/.. $(TAR_OPTIONS)
UNZIP_CMD=unzip -d $(1)/.. $(DL_DIR)/$(PKG_SOURCE)
diff --git
a/rules.mk
b/rules.mk
index 5d6322733994614991ddbad717b089a3fb1f6911..0769a09278270e92bec1c1c24ec9b5fd0e7ad7e9 100644
(file)
--- a/
rules.mk
+++ b/
rules.mk
@@
-272,12
+272,6
@@
else
DISABLE_IPV6:=--disable-ipv6
endif
-ifeq ($(CONFIG_TAR_VERBOSITY),y)
- TAR_OPTIONS:=-xvf -
-else
- TAR_OPTIONS:=-xf -
-endif
-
ifeq ($(CONFIG_BUILD_LOG),y)
BUILD_LOG:=1
endif