busybox: fix dependency for IPV6
authorRosy Song <rosysong@rosinson.com>
Sat, 22 Sep 2018 13:15:40 +0000 (21:15 +0800)
committerJo-Philipp Wich <jo@mein.io>
Tue, 18 Dec 2018 16:47:57 +0000 (17:47 +0100)
Signed-off-by: Rosy Song <rosysong@rosinson.com>
(backported from 9f0cb135dd4078f4df89978abb0f96326133da2c)

package/utils/busybox/Makefile
package/utils/busybox/config/networking/Config.in

index 129aec19d6e8b0658754e0995c9d60d1fd47e230..6a761b45989512864f90ba6414ffc93ad555a4b6 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.29.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_FLAGS:=essential
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index 2d2a1c4a9e7c27d66b72f32930f7b6f2b86615cc..2071fd015edf62a00de4ffc574cc8bdc04001c86 100644 (file)
@@ -9,6 +9,7 @@ menu "Networking Utilities"
 config BUSYBOX_CONFIG_FEATURE_IPV6
        bool "Enable IPv6 support"
        default BUSYBOX_DEFAULT_FEATURE_IPV6
+       depends on IPV6
        help
          Enable IPv6 support in busybox.
          This adds IPv6 support in the networking applets.