update ser to openser 1.0, most work from Michael Poehnl - Milkfish poject
authorWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Tue, 31 Jan 2006 15:48:11 +0000 (15:48 +0000)
committerWaldemar Brodkorb <mail@waldemar-brodkorb.de>
Tue, 31 Jan 2006 15:48:11 +0000 (15:48 +0000)
SVN-Revision: 3091

21 files changed:
openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/openser/Config.in [new file with mode: 0644]
openwrt/package/openser/Makefile [new file with mode: 0644]
openwrt/package/openser/ipkg/openser.conffiles [new file with mode: 0644]
openwrt/package/openser/ipkg/openser.control [new file with mode: 0644]
openwrt/package/openser/patches/Makefile.defs.patch [new file with mode: 0644]
openwrt/package/openser/patches/cfg.lex.patch [new file with mode: 0644]
openwrt/package/openser/patches/config.h.patch [new file with mode: 0644]
openwrt/package/openser/patches/openser.cfg.patch [new file with mode: 0644]
openwrt/package/openser/patches/sc.dbtext.patch [new file with mode: 0644]
openwrt/package/openser/patches/sc.patch [new file with mode: 0644]
openwrt/package/ser/Config.in [deleted file]
openwrt/package/ser/Makefile [deleted file]
openwrt/package/ser/patches/100-sc.patch [deleted file]
openwrt/package/ser/patches/110-locking.patch [deleted file]
openwrt/package/ser/patches/120-main.patch [deleted file]
openwrt/package/ser/patches/200-no_libfl.patch [deleted file]
openwrt/package/ser/patches/210-runtime_paths.patch [deleted file]
openwrt/package/ser/patches/220-default_config.patch [deleted file]
openwrt/package/ser/ser.control [deleted file]

index 681f4390bd3336b575fce31e07376f58229e6c91..76109712a988d5509d9be5f6ca561dcaecfe7dc4 100644 (file)
@@ -58,6 +58,7 @@ source "package/nocatsplash/Config.in"
 source "package/ntpclient/Config.in"
 source "package/olsrd/Config.in"
 source "package/openntpd/Config.in"
+source "package/openser/Config.in"
 source "package/openssh/Config.in"
 source "package/openswan/Config.in"
 source "package/openvpn/Config.in"
@@ -70,7 +71,6 @@ source "package/quagga/Config.in"
 source "package/radvd/Config.in"
 source "package/robocfg/Config.in"
 source "package/rsync/Config.in"
-source "package/ser/Config.in"
 source "package/shat/Config.in"
 source "package/siproxd/Config.in"
 source "package/sipsak/Config.in"
index 80048683d29a15f3d1dec7f2695e07d6ebc6cdd0..5c3d5ac48e46122dc58649942a1f4aa845bbe567 100644 (file)
@@ -71,6 +71,7 @@ package-$(BR2_PACKAGE_NTPCLIENT) += ntpclient
 package-$(BR2_PACKAGE_OLSRD) += olsrd
 package-$(BR2_PACKAGE_OPENLDAP) += openldap
 package-$(BR2_PACKAGE_OPENNTPD) += openntpd
+package-$(BR2_PACKAGE_OPENSER) += openser
 package-$(BR2_PACKAGE_OPENSSH) += openssh
 package-$(BR2_PACKAGE_OPENSSL) += openssl
 package-$(BR2_PACKAGE_OPENSWAN) += openswan
@@ -94,7 +95,6 @@ package-$(BR2_PACKAGE_SABLEVM) += sablevm
 package-$(BR2_PACKAGE_SABLEVM_CLASSPATH) += sablevm-classpath
 package-$(BR2_PACKAGE_SCREEN) += screen
 package-$(BR2_PACKAGE_SDK) += sdk
-package-$(BR2_PACKAGE_SER) += ser
 package-$(BR2_PACKAGE_SETSERIAL) += setserial
 package-$(BR2_PACKAGE_SHAT) += shat
 package-$(BR2_PACKAGE_SHFS) += shfs
diff --git a/openwrt/package/openser/Config.in b/openwrt/package/openser/Config.in
new file mode 100644 (file)
index 0000000..f00d5a7
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_OPENSER
+       tristate "openser - configurable, free SIP server"
+       default m if CONFIG_DEVEL
+       help
+        Open SIP Express Router (OpenSER) is a high-performance,
+        configurable, free SIP server.
+
diff --git a/openwrt/package/openser/Makefile b/openwrt/package/openser/Makefile
new file mode 100644 (file)
index 0000000..29d7286
--- /dev/null
@@ -0,0 +1,58 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=openser
+PKG_VERSION:=1.0.0
+PKG_RELEASE:=1
+PKG_MD5SUM:=f60f5a51772c5b06abaa1c81e9539077
+# PKG_VARIANT:=-tls for tls version
+PKG_VARIANT:=
+
+PKG_SOURCE_URL:=http://openser.org/pub/openser/$(PKG_VERSION)/src
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)$(PKG_VARIANT)_src.tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,OPENSER,openser,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+# Select here the modules for the ipk package
+OPENSER_MODULES := sl tm rr maxfwd usrloc registrar dbtext textops exec
+
+OPENSER_MODULE_FILES := $(foreach module,$(OPENSER_MODULES),modules/$(module)/$(module).so)
+OPENSER_MODULES := $(patsubst %,modules/%,$(OPENSER_MODULES))
+
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               prefix=/ \
+               extra_defs="-DUSE_PTHREAD_MUTEX "  \
+               CC="$(TARGET_CC)" \
+               ARCH="$(ARCH)"  \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               LOCALBASE="$(STAGING_DIR)/usr" \
+               all utils/gen_ha1/gen_ha1
+       touch $@
+
+$(IPKG_OPENSER): 
+       mkdir -p $(IDIR_OPENSER)/usr/sbin
+       cp -fpR $(PKG_BUILD_DIR)/$(PKG_NAME) $(IDIR_OPENSER)/usr/sbin/
+       cp -fpR $(PKG_BUILD_DIR)/utils/gen_ha1/gen_ha1 $(IDIR_OPENSER)/usr/sbin/openser_gen_ha1
+       cp -fpR $(PKG_BUILD_DIR)/scripts/sc $(IDIR_OPENSER)/usr/sbin/openserctl
+       chmod 744 $(IDIR_OPENSER)/usr/sbin/openserctl
+       cp -fpR $(PKG_BUILD_DIR)/scripts/sc.dbtext $(IDIR_OPENSER)/usr/sbin/dbtextctl
+       chmod 744 $(IDIR_OPENSER)/usr/sbin/dbtextctl
+       mkdir -p $(IDIR_OPENSER)/usr/lib/openser/modules
+       (cd $(PKG_BUILD_DIR);\
+               cp -a $(OPENSER_MODULE_FILES) $(IDIR_OPENSER)/usr/lib/openser/modules/; \
+       )
+       mkdir -p $(IDIR_OPENSER)/etc/openser
+       cp -fpR $(PKG_BUILD_DIR)/etc/openser.cfg $(IDIR_OPENSER)/etc/openser/
+       $(RSTRIP) $(IDIR_OPENSER)
+       $(IPKG_BUILD) $(IDIR_OPENSER) $(PACKAGE_DIR)
diff --git a/openwrt/package/openser/ipkg/openser.conffiles b/openwrt/package/openser/ipkg/openser.conffiles
new file mode 100644 (file)
index 0000000..edd06eb
--- /dev/null
@@ -0,0 +1 @@
+/etc/openser/openser.cfg
diff --git a/openwrt/package/openser/ipkg/openser.control b/openwrt/package/openser/ipkg/openser.control
new file mode 100644 (file)
index 0000000..a0b9863
--- /dev/null
@@ -0,0 +1,7 @@
+Package: openser
+Priority: optional
+Section: net
+Maintainer: Michael Poehnl <budrus@berlios.de>
+Description: OpenSER
+ OpenSER is a high-performance,
+ configurable, free SIP server.
diff --git a/openwrt/package/openser/patches/Makefile.defs.patch b/openwrt/package/openser/patches/Makefile.defs.patch
new file mode 100644 (file)
index 0000000..a7275bd
--- /dev/null
@@ -0,0 +1,71 @@
+--- openser-1.0.0-tls.orig/Makefile.defs       2005-10-28 18:32:39.000000000 +0200
++++ openser-1.0.0-tls/Makefile.defs    2006-01-15 23:40:18.391547040 +0100
+@@ -917,7 +917,7 @@
+ endif
+ YACC_FLAGS=-d -b cfg
+ # on solaris add -lxnet (e.g. LIBS= -lxnet)
+-LIBS= -lfl -ldl -lresolv
++LIBS= -ldl -lresolv
+ #os specific stuff
+@@ -955,7 +955,7 @@
+ endif
+       OLD_SOLARIS= $(shell echo "$(OSREL)" | \
+                               sed -e 's/^5\.[0-6][^0-9]*$$/yes/' )
+-      LIBS+= -L$(LOCALBASE)/lib -lfl -lxnet -lnsl 
++      LIBS+= -L$(LOCALBASE)/lib -lxnet -lnsl 
+ ifeq  ($(OLD_SOLARIS), yes)
+               LIBS+=-lposix4
+ else
+@@ -970,9 +970,9 @@
+       ifneq ($(found_lock_method), yes)
+               DEFS+= -DUSE_PTHREAD_MUTEX  # try pthread sems
+               found_lock_method=yes
+-              LIBS= -pthread -lfl  #dlopen is in libc
++              LIBS= -pthread  #dlopen is in libc
+       else
+-              LIBS= -lfl  #dlopen is in libc
++              LIBS=  #dlopen is in libc
+       endif
+       YACC=yacc
+ endif
+@@ -987,7 +987,7 @@
+       # (symbols on openbsd are prefixed by "_")
+       YACC=yacc
+       # no sched_yield on openbsd unless linking with c_r (not recommended)
+-      LIBS= -lfl 
++      LIBS= 
+       OPENBSD_IS_AOUT= $(shell echo "$(OSREL)" | \
+                               sed -e 's/^3\.[0-3][^0-9]*$$/yes/' |sed -e 's/^[0-2]\..*/yes/')
+ # exception: on sparc openbsd 3.2 is elf and not aout
+@@ -1014,7 +1014,7 @@
+               found_lock_method=yes
+       endif
+       YACC=yacc
+-      LIBS= -lfl 
++      LIBS= 
+ endif
+ # OS X support, same as freebsd
+@@ -1028,9 +1028,9 @@
+       ifneq ($(found_lock_method), yes)
+               DEFS+= -DUSE_PTHREAD_MUTEX  # try pthread sems
+               found_lock_method=yes
+-              LIBS= -pthread -lfl -lresolv  #dlopen is in libc
++              LIBS= -pthread -lresolv  #dlopen is in libc
+       else
+-              LIBS= -lfl -lresolv  #dlopen is in libc
++              LIBS= -lresolv  #dlopen is in libc
+       endif
+       LDFLAGS=        # darwin doesn't like -O2 or -E
+       MOD_LDFLAGS= -bundle -bundle_loader ../../$(MAIN_NAME)
+@@ -1047,7 +1047,7 @@
+ #add libssl if needed
+ ifneq ($(TLS),)
+-DEFS+= -I$(LOCALBASE)/ssl/include
++DEFS+= -I$(LOCALBASE)/include
+ LIBS+= -L$(LOCALBASE)/lib -L$(LOCALBASE)/ssl/lib -lssl  -lcrypto
+ endif
diff --git a/openwrt/package/openser/patches/cfg.lex.patch b/openwrt/package/openser/patches/cfg.lex.patch
new file mode 100644 (file)
index 0000000..39eacb2
--- /dev/null
@@ -0,0 +1,13 @@
+--- openser-1.0.0-tls.orig/cfg.lex     2005-09-02 17:34:41.000000000 +0200
++++ openser-1.0.0-tls/cfg.lex  2006-01-05 01:34:50.279630928 +0100
+@@ -85,6 +85,10 @@
+       static char* addstr(struct str_buf *, char*, int);
+       static void count();
++      int yywrap(void)
++      {
++              return 1;
++      }
+ %}
diff --git a/openwrt/package/openser/patches/config.h.patch b/openwrt/package/openser/patches/config.h.patch
new file mode 100644 (file)
index 0000000..45af8f1
--- /dev/null
@@ -0,0 +1,33 @@
+--- openser-1.0.0-tls.orig/config.h    2005-08-23 19:31:12.000000000 +0200
++++ openser-1.0.0-tls/config.h 2006-01-05 01:42:14.101159800 +0100
+@@ -48,7 +48,7 @@
+ #define MAX_LISTEN 16
+ /* default number of child processes started */
+-#define CHILD_NO    8
++#define CHILD_NO    4
+ #define RT_NO 40 /* routing tables number */
+ #define FAILURE_RT_NO RT_NO /* on_failure routing tables number */
+@@ -68,10 +68,10 @@
+ #define CONTENT_LENGTH "Content-Length: "
+ #define CONTENT_LENGTH_LEN (sizeof(CONTENT_LENGTH)-1)
+-#define USER_AGENT "User-Agent: OpenSer (" VERSION " (" ARCH "/" OS"))"
++#define USER_AGENT "User-Agent: OpenSer " VERSION " (boozy.milkfish.org)"
+ #define USER_AGENT_LEN (sizeof(USER_AGENT)-1)
+-#define SERVER_HDR "Server: OpenSer (" VERSION " (" ARCH "/" OS"))"
++#define SERVER_HDR "Server: OpenSer " VERSION " (boozy.milkfish.org)"
+ #define SERVER_HDR_LEN (sizeof(SERVER_HDR)-1)
+ #define MAX_WARNING_LEN  256
+@@ -113,7 +113,7 @@
+ #define PKG_MEM_POOL_SIZE 1024*1024
+ /*used if SH_MEM is defined*/
+-#define SHM_MEM_SIZE 32
++#define SHM_MEM_SIZE 8
+ #define TIMER_TICK 1
diff --git a/openwrt/package/openser/patches/openser.cfg.patch b/openwrt/package/openser/patches/openser.cfg.patch
new file mode 100644 (file)
index 0000000..f26e79e
--- /dev/null
@@ -0,0 +1,33 @@
+--- openser-1.0.0-tls.orig/etc/openser.cfg     2005-10-28 21:45:33.000000000 +0200
++++ openser-1.0.0-tls/etc/openser.cfg  2006-01-07 01:39:01.077134312 +0100
+@@ -36,20 +36,20 @@
+ # ------------------ module loading ----------------------------------
+ # Uncomment this if you want to use SQL database
+-#loadmodule "/usr/local/lib/openser/modules/mysql.so"
++#loadmodule "/usr/lib/openser/modules/mysql.so"
+-loadmodule "/usr/local/lib/openser/modules/sl.so"
+-loadmodule "/usr/local/lib/openser/modules/tm.so"
+-loadmodule "/usr/local/lib/openser/modules/rr.so"
+-loadmodule "/usr/local/lib/openser/modules/maxfwd.so"
+-loadmodule "/usr/local/lib/openser/modules/usrloc.so"
+-loadmodule "/usr/local/lib/openser/modules/registrar.so"
+-loadmodule "/usr/local/lib/openser/modules/textops.so"
++loadmodule "/usr/lib/openser/modules/sl.so"
++loadmodule "/usr/lib/openser/modules/tm.so"
++loadmodule "/usr/lib/openser/modules/rr.so"
++loadmodule "/usr/lib/openser/modules/maxfwd.so"
++loadmodule "/usr/lib/openser/modules/usrloc.so"
++loadmodule "/usr/lib/openser/modules/registrar.so"
++loadmodule "/usr/lib/openser/modules/textops.so"
+ # Uncomment this if you want digest authentication
+ # mysql.so must be loaded !
+-#loadmodule "/usr/local/lib/openser/modules/auth.so"
+-#loadmodule "/usr/local/lib/openser/modules/auth_db.so"
++#loadmodule "/usr/lib/openser/modules/auth.so"
++#loadmodule "/usr/lib/openser/modules/auth_db.so"
+ # ----------------- setting module-specific parameters ---------------
diff --git a/openwrt/package/openser/patches/sc.dbtext.patch b/openwrt/package/openser/patches/sc.dbtext.patch
new file mode 100644 (file)
index 0000000..2a1b7ea
--- /dev/null
@@ -0,0 +1,22 @@
+--- openser-1.0.0-tls.orig/scripts/sc.dbtext   2005-07-29 21:05:36.000000000 +0200
++++ openser-1.0.0-tls/scripts/sc.dbtext        2006-01-29 02:30:31.795349688 +0100
+@@ -62,6 +62,10 @@
+ ##### ----------------------------------------------- #####
+ #### table names
++if [ -z "$SIP_DOMAIN" ] ; then
++      SIP_DOMAIN=$(nvram get sip_domain)
++fi
++
+ # UsrLoc Table
+ if [ -z "$UL_TABLE" ] ; then
+       UL_TABLE=location
+@@ -247,7 +251,7 @@
+       fi
+       if [ -z "$SERDOMAIN" ] ; then
+-              echo -e "\nDomain unknown: use usernames with domain or set default domain in SIP_DOMAIN\n"
++              echo -e "\nDomain unknown: use usernames with domain or set default domain in SIP_DOMAIN (with 'nvram set sip_domain=YOUR_SIP_DOMAIN')\n"
+               exit 1
+       fi
+ }
diff --git a/openwrt/package/openser/patches/sc.patch b/openwrt/package/openser/patches/sc.patch
new file mode 100644 (file)
index 0000000..52ef9a6
--- /dev/null
@@ -0,0 +1,41 @@
+--- openser-1.0.0-tls.orig/scripts/sc  2005-08-11 14:08:02.000000000 +0200
++++ openser-1.0.0-tls/scripts/sc       2006-01-29 02:18:43.319054456 +0100
+@@ -48,11 +48,15 @@
+       STARTOPTIONS= # for example -dddd
+ fi
+ if [ -z "$DIR" ] ; then
+-      DIR=`dirname $0`
++      DIR=/usr/sbin
+ fi
+ if [ -z "$SERBIN" ] ; then
+       SERBIN=$DIR/openser
+ fi
++if [ -z "$SIP_DOMAIN" ] ; then
++      SIP_DOMAIN=$(nvram get sip_domain)
++fi
++
+ ##### ----------------------------------------------- #####
+ ### openser's FIFO server
+@@ -415,7 +419,7 @@
+       fi
+       if [ -z "$SERDOMAIN" ] ; then
+-              echo "domain unknown: use usernames with domain or set default domain in SIP_DOMAIN"
++              echo "domain unknown: use usernames with domain or set default domain in SIP_DOMAIN (with 'nvram set sip_domain=YOUR_SIP_DOMAIN')"
+               exit 1
+       fi
+ }
+@@ -671,11 +675,7 @@
+                               set_user $2
+                               fifo_cmd ul_show_contact $USRLOC_TABLE "$SERUSER@$SERDOMAIN"
+                       elif [ $# -eq 1 ] ; then
+-                              printf "Dumping all contacts may take long: are you sure you want to proceed? [Y|N] " > /dev/stderr
+-                              read answer
+-                              if [ "$answer" = "y" -o "$answer" = "Y" ] ; then
+-                                      fifo_cmd ul_dump
+-                              fi
++                              fifo_cmd ul_dump
+                       else
+                               echo "wrong number of params for usrloc show"
+                               usage
diff --git a/openwrt/package/ser/Config.in b/openwrt/package/ser/Config.in
deleted file mode 100644 (file)
index ede98e5..0000000
+++ /dev/null
@@ -1,7 +0,0 @@
-config BR2_PACKAGE_SER
-       tristate "SIP Express Router"
-       default m if CONFIG_DEVEL
-       help
-        SIP Express Router (ser) is a high-performance,
-        configurable, free SIP server.
-
diff --git a/openwrt/package/ser/Makefile b/openwrt/package/ser/Makefile
deleted file mode 100644 (file)
index 81cb347..0000000
+++ /dev/null
@@ -1,65 +0,0 @@
-# $Id$
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=ser
-PKG_VERSION:=0.8.14
-PKG_RELEASE:=1
-PKG_MD5SUM:=3e2e12c8dfbd7dad9199304093de0838
-
-PKG_SOURCE_URL:=ftp://ftp.berlios.de/pub/ser/$(PKG_VERSION)/src
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)_src.tar.gz
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_CAT:=zcat
-PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
-PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
-
-SER_MODULES := sl tm rr maxfwd usrloc registrar dbtext textops nathelper
-
-SER_MODULE_FILES := $(foreach module,$(SER_MODULES),modules/$(module)/$(module).so)
-SER_MODULES := $(patsubst %,modules/%,$(SER_MODULES))
-
-$(DL_DIR)/$(PKG_SOURCE):
-       $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
-
-$(PKG_BUILD_DIR)/.patched: $(DL_DIR)/$(PKG_SOURCE)
-       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-       $(PATCH) $(PKG_BUILD_DIR) ./patches
-       touch $(PKG_BUILD_DIR)/.patched
-
-$(PKG_BUILD_DIR)/$(PKG_NAME): $(PKG_BUILD_DIR)/.patched
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               extra_defs="-DUSE_PTHREAD_MUTEX "  \
-               CC="$(TARGET_CC)" \
-               ARCH="$(ARCH)" \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               modules all
-
-$(PKG_IPK): $(PKG_BUILD_DIR)/$(PKG_NAME)
-       $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
-       mkdir -p $(PKG_IPK_DIR)/usr/sbin
-       cp -a $(PKG_BUILD_DIR)/$(PKG_NAME) $(PKG_IPK_DIR)/usr/sbin/
-       -$(STRIP) $(PKG_IPK_DIR)/usr/sbin/*
-       cp -a $(PKG_BUILD_DIR)/scripts/sc $(PKG_IPK_DIR)/usr/sbin/serctl
-       mkdir -p $(PKG_IPK_DIR)/usr/lib/ser/modules
-       (cd $(PKG_BUILD_DIR);\
-               cp -a $(SER_MODULE_FILES) $(PKG_IPK_DIR)/usr/lib/ser/modules/; \
-       )
-       $(STRIP) $(PKG_IPK_DIR)/usr/lib/ser/modules/*
-       mkdir -p $(PKG_IPK_DIR)/etc/ser
-       cp -a $(PKG_BUILD_DIR)/etc/ser.cfg $(PKG_IPK_DIR)/etc/ser/
-       mkdir -p $(PACKAGE_DIR)
-       $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
-
-$(IPKG_STATE_DIR)/info/$(PKG_NAME).list: $(PKG_IPK)
-       $(IPKG) install $(PKG_IPK)
-
-source: $(DL_DIR)/$(PKG_SOURCE)
-prepare: $(PKG_BUILD_DIR)/.patched
-compile: $(PKG_IPK)
-install: $(IPKG_STATE_DIR)/info/$(PKG_NAME).list
-
-
-clean:
-       rm -rf $(PKG_BUILD_DIR)
-       rm -f $(PKG_IPK)
diff --git a/openwrt/package/ser/patches/100-sc.patch b/openwrt/package/ser/patches/100-sc.patch
deleted file mode 100644 (file)
index 25ecb9b..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
---- ser-0.8.14.orig/scripts/sc 2004-07-27 11:41:40.000000000 +0200
-+++ ser-0.8.14/scripts/sc      2005-02-07 23:10:30.000000000 +0100
-@@ -19,7 +19,7 @@
- # configuration for starting/stopping ser
- PID_FILE=/var/run/ser.pid
- SYSLOG=1 # 0=output to console, 1=output to syslog
--STARTOPTIONS= # for example -dddd
-+STARTOPTIONS="-m 5"
- # ser's FIFO server
- if [ -z "$SER_FIFO" ]; then
-@@ -338,11 +338,7 @@
-                       if [ $# -eq 2 ] ; then
-                               fifo_cmd ul_show_contact $UL_TABLE $2
-                       elif [ $# -eq 1 ] ; then
--                              printf "Dumping all contacts may take long: are you sure you want to proceed? [Y|N] "
--                              read answer
--                              if [ "$answer" = "y" -o "$answer" = "Y" ] ; then
--                                      fifo_cmd ul_dump
--                              fi
-+                              fifo_cmd ul_dump
-                       else
-                               echo "wrong number of params for usrloc show"
-                               usage
-@@ -590,7 +586,7 @@
- case $1 in
-       start)
--              DIR=`dirname $0`
-+              DIR=/usr/sbin
-               echo
-               printf "Starting SER : "
-               if [ -r $PID_FILE ] ; then
-@@ -612,6 +608,7 @@
-               printf "Stopping SER : "
-               if [ -r $PID_FILE ] ; then
-                       kill `cat $PID_FILE`
-+                        rm $PID_FILE
-                       echo "stopped"
-               else
-                       echo No PID file found!
-@@ -621,10 +618,11 @@
-       ;;
-       restart)
--              DIR=`dirname $0`
-+              DIR=/usr/sbin
-               printf "Stopping SER : "
-               if [ -r $PID_FILE ] ; then
-                       kill `cat $PID_FILE`
-+                        rm $PID_FILE
-                       echo "stopped"
-               else
-                       echo No PID file found! SER problably not running
diff --git a/openwrt/package/ser/patches/110-locking.patch b/openwrt/package/ser/patches/110-locking.patch
deleted file mode 100644 (file)
index 196f714..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- ser-0.8.14.orig/locking.h  2004-07-27 01:18:35.000000000 +0200
-+++ ser-0.8.14/locking.h       2004-12-26 15:39:03.000000000 +0100
-@@ -67,6 +67,8 @@
- #define _locking_h
- /* the order is important */
-+#include <errno.h>
-+#include "dprint.h"
- #include "lock_ops.h"
- #include "lock_alloc.h" 
diff --git a/openwrt/package/ser/patches/120-main.patch b/openwrt/package/ser/patches/120-main.patch
deleted file mode 100644 (file)
index eacd0cc..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
---- ser-0.8.14.orig/main.c     2004-06-28 17:41:21.000000000 +0200
-+++ ser-0.8.14/main.c  2005-01-07 23:24:27.000000000 +0100
-@@ -1447,18 +1447,20 @@
-       /* seed the prng */
-       /* try to use /dev/random if possible */
-       seed=0;
-+/* this read call is blocking on OpenWRT, further investigations are necessary
-       if ((rfd=open("/dev/random", O_RDONLY))!=-1){
- try_again:
-               if (read(rfd, (void*)&seed, sizeof(seed))==-1){
--                      if (errno==EINTR) goto try_again; /* interrupted by signal */
-+                      if (errno==EINTR) goto try_again; 
-                       LOG(L_WARN, "WARNING: could not read from /dev/random (%d)\n",
-                                               errno);
-               }
-               DBG("read %u from /dev/random\n", seed);
-                       close(rfd);
-       }else{
--              LOG(L_WARN, "WARNING: could not open /dev/random (%d)\n", errno);
--      }
-+*/
-+              LOG(L_WARN, "WARNING: could not read from /dev/random (%d)\n", errno);
-+//    }
-       seed+=getpid()+time(0);
-       DBG("seeding PRNG with %u\n", seed);
-       srand(seed);
diff --git a/openwrt/package/ser/patches/200-no_libfl.patch b/openwrt/package/ser/patches/200-no_libfl.patch
deleted file mode 100644 (file)
index 93533ab..0000000
+++ /dev/null
@@ -1,79 +0,0 @@
-Binary files ser-0.8.14.old/.cfg.lex.swp and ser-0.8.14.dev/.cfg.lex.swp differ
-diff -urN ser-0.8.14.old/Makefile.defs ser-0.8.14.dev/Makefile.defs
---- ser-0.8.14.old/Makefile.defs       2004-07-27 13:38:33.000000000 +0200
-+++ ser-0.8.14.dev/Makefile.defs       2005-05-01 01:18:12.000000000 +0200
-@@ -660,7 +660,7 @@
- endif
- YACC_FLAGS=-d -b cfg
- # on solaris add -lxnet (e.g. LIBS= -lxnet)
--LIBS= -lfl -ldl -lresolv
-+LIBS=  -ldl -lresolv
- #os specific stuff
-@@ -695,7 +695,7 @@
- ifeq ($(CC_NAME), suncc)
-       LIBS= -lfast -ldl -lresolv
- endif
--      LIBS+= -L/usr/local/lib -lfl -lxnet -lrt -lnsl 
-+      LIBS+= -L/usr/local/lib  -lxnet -lrt -lnsl 
-       # -lrt needed for sched_yield
- endif
-@@ -705,9 +705,9 @@
-       ifneq ($(found_lock_method), yes)
-               DEFS+= -DUSE_PTHREAD_MUTEX  # try pthread sems
-               found_lock_method=yes
--              LIBS= -pthread -lfl  #dlopen is in libc
-+              LIBS= -pthread   #dlopen is in libc
-       else
--              LIBS= -lfl  #dlopen is in libc
-+              LIBS=   #dlopen is in libc
-       endif
-       YACC=yacc
- endif
-@@ -722,7 +722,7 @@
-       # (symbols on openbsd are prefixed by "_")
-       YACC=yacc
-       # no sched_yield on openbsd unless linking with c_r (not recommended)
--      LIBS= -lfl 
-+      LIBS=  
-       OPENBSD_IS_AOUT= $(shell echo "$(OSREL)" | \
-                               sed -e 's/^3\.[0-3][^0-9]*$$/yes/' |sed -e 's/^[0-2]\..*/yes/')
-       
-@@ -740,7 +740,7 @@
-               found_lock_method=yes
-       endif
-       YACC=yacc
--      LIBS= -lfl 
-+      LIBS=  
- endif
- # OS X support, same as freebsd
-@@ -754,9 +754,9 @@
-       ifneq ($(found_lock_method), yes)
-               DEFS+= -DUSE_PTHREAD_MUTEX  # try pthread sems
-               found_lock_method=yes
--              LIBS= -pthread -lfl -lresolv  #dlopen is in libc
-+              LIBS= -pthread  -lresolv  #dlopen is in libc
-       else
--              LIBS= -lfl -lresolv  #dlopen is in libc
-+              LIBS=  -lresolv  #dlopen is in libc
-       endif
-       LDFLAGS=        # darwin doesn't like -O2 or -E
-       MOD_LDFLAGS= -bundle -bundle_loader ../../$(MAIN_NAME)
-diff -urN ser-0.8.14.old/cfg.lex ser-0.8.14.dev/cfg.lex
---- ser-0.8.14.old/cfg.lex     2004-02-12 17:17:48.000000000 +0100
-+++ ser-0.8.14.dev/cfg.lex     2005-05-01 01:23:03.000000000 +0200
-@@ -71,7 +71,10 @@
-       static char* addstr(char*, char**);
-       static void count();
--
-+      int yywrap(void)
-+      {
-+              return 1;
-+      }
- %}
diff --git a/openwrt/package/ser/patches/210-runtime_paths.patch b/openwrt/package/ser/patches/210-runtime_paths.patch
deleted file mode 100644 (file)
index 5d30e11..0000000
+++ /dev/null
@@ -1,122 +0,0 @@
-diff -urN ser-0.8.14.old/Makefile ser-0.8.14.dev/Makefile
---- ser-0.8.14.old/Makefile    2004-07-27 01:18:34.000000000 +0200
-+++ ser-0.8.14.dev/Makefile    2005-05-01 01:29:25.000000000 +0200
-@@ -194,8 +194,8 @@
- # binary dist. tar.gz
- .PHONY: bin
- bin:
--      mkdir -p tmp/ser/usr/local
--      $(MAKE) install basedir=tmp/ser prefix=/usr/local 
-+      mkdir -p tmp/ser/usr
-+      $(MAKE) install basedir=tmp/ser prefix=/usr 
-       $(TAR) -C tmp/ser/ -zcf ../$(NAME)-$(RELEASE)_$(OS)_$(ARCH).tar.gz .
-       rm -rf tmp/ser
-@@ -207,9 +207,9 @@
- sunpkg:
-       mkdir -p tmp/ser
-       mkdir -p tmp/ser_sun_pkg
--      $(MAKE) install basedir=tmp/ser prefix=/usr/local
-+      $(MAKE) install basedir=tmp/ser prefix=/usr
-       (cd solaris; \
--      pkgmk -r ../tmp/ser/usr/local -o -d ../tmp/ser_sun_pkg/ -v "$(RELEASE)" ;\
-+      pkgmk -r ../tmp/ser/usr -o -d ../tmp/ser_sun_pkg/ -v "$(RELEASE)" ;\
-       cd ..)
-       cat /dev/null > ../$(NAME)-$(RELEASE)-$(OS)-$(ARCH)-local
-       pkgtrans -s tmp/ser_sun_pkg/ ../$(NAME)-$(RELEASE)-$(OS)-$(ARCH)-local \
-diff -urN ser-0.8.14.old/Makefile.defs ser-0.8.14.dev/Makefile.defs
---- ser-0.8.14.old/Makefile.defs       2005-05-01 01:18:12.000000000 +0200
-+++ ser-0.8.14.dev/Makefile.defs       2005-05-01 01:42:55.000000000 +0200
-@@ -64,20 +64,20 @@
- # extra CC command line options (e.g  -march=athlon-mp)
- CC_EXTRA_OPTS ?=
-  # install location
--DESTDIR ?= /usr/local
-+DESTDIR ?= /usr
- PREFIX ?= $(DESTDIR)
--LOCALBASE ?= /usr/local
-+LOCALBASE ?= /usr
- prefix = $(PREFIX)
- # install path is $(basedir) $(prefix) 
- # example:
--#  creating a bin. archive in /tmp, which unpacks in /usr/local
-+#  creating a bin. archive in /tmp, which unpacks in /usr
- #  basedir=/tmp
--#  prefix=/usr/local
-+#  prefix=/usr
- BASEDIR ?=
- basedir = $(BASEDIR)
- # install prefixes for various stuff
--cfg-prefix = $(basedir)$(prefix)
-+cfg-prefix = /
- bin-prefix = $(basedir)$(prefix)
- modules-prefix = $(basedir)$(prefix)
- doc-prefix = $(basedir)$(prefix)
-@@ -117,7 +117,7 @@
- endif
- ut-prefix = bin/
- # target dirs for various stuff
--cfg-target = $(prefix)/$(cfg-dir)
-+cfg-target = /$(cfg-dir)
- modules-target = $(prefix)/$(modules-dir)
-@@ -688,14 +688,14 @@
-               #MOD_LDFLAGS=-g -G
-       endif
- ifneq ($(TLS),)
--      DEFS+= -I/usr/local/ssl/include
-+      DEFS+= -I/usr/ssl/include
- endif
-       YACC=yacc
- ifeq ($(CC_NAME), suncc)
-       LIBS= -lfast -ldl -lresolv
- endif
--      LIBS+= -L/usr/local/lib  -lxnet -lrt -lnsl 
-+      LIBS+= -L/usr/lib  -lxnet -lrt -lnsl 
-       # -lrt needed for sched_yield
- endif
-@@ -773,7 +773,7 @@
- #add libssl if needed
- ifneq ($(TLS),)
--LIBS+= -L/usr/local/lib -L/usr/local/ssl/lib -lssl  -lcrypto
-+LIBS+= -L/usr/lib -L/usr/ssl/lib -lssl  -lcrypto
- endif
- ifneq ($(found_lock_method), yes)
-diff -urN ser-0.8.14.old/etc/ser.cfg ser-0.8.14.dev/etc/ser.cfg
---- ser-0.8.14.old/etc/ser.cfg 2003-11-10 16:35:15.000000000 +0100
-+++ ser-0.8.14.dev/etc/ser.cfg 2005-05-01 01:28:43.000000000 +0200
-@@ -26,19 +26,19 @@
- # ------------------ module loading ----------------------------------
- # Uncomment this if you want to use SQL database
--#loadmodule "/usr/local/lib/ser/modules/mysql.so"
-+#loadmodule "/usr/lib/ser/modules/mysql.so"
--loadmodule "/usr/local/lib/ser/modules/sl.so"
--loadmodule "/usr/local/lib/ser/modules/tm.so"
--loadmodule "/usr/local/lib/ser/modules/rr.so"
--loadmodule "/usr/local/lib/ser/modules/maxfwd.so"
--loadmodule "/usr/local/lib/ser/modules/usrloc.so"
--loadmodule "/usr/local/lib/ser/modules/registrar.so"
-+loadmodule "/usr/lib/ser/modules/sl.so"
-+loadmodule "/usr/lib/ser/modules/tm.so"
-+loadmodule "/usr/lib/ser/modules/rr.so"
-+loadmodule "/usr/lib/ser/modules/maxfwd.so"
-+loadmodule "/usr/lib/ser/modules/usrloc.so"
-+loadmodule "/usr/lib/ser/modules/registrar.so"
- # Uncomment this if you want digest authentication
- # mysql.so must be loaded !
--#loadmodule "/usr/local/lib/ser/modules/auth.so"
--#loadmodule "/usr/local/lib/ser/modules/auth_db.so"
-+#loadmodule "/usr/lib/ser/modules/auth.so"
-+#loadmodule "/usr/lib/ser/modules/auth_db.so"
- # ----------------- setting module-specific parameters ---------------
diff --git a/openwrt/package/ser/patches/220-default_config.patch b/openwrt/package/ser/patches/220-default_config.patch
deleted file mode 100644 (file)
index 7a766f2..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -urN ser-0.8.14.old/config.h ser-0.8.14.dev/config.h
---- ser-0.8.14.old/config.h    2004-04-27 22:28:59.000000000 +0200
-+++ ser-0.8.14.dev/config.h    2005-05-01 01:48:00.000000000 +0200
-@@ -53,7 +53,7 @@
- #define MAX_LISTEN 16
- /* default number of child processes started */
--#define CHILD_NO    8
-+#define CHILD_NO    2
- #define RT_NO 20 /* routing tables number */
- #define FAILURE_RT_NO RT_NO /* on_failure routing tables number */
-@@ -117,7 +117,7 @@
- #define PKG_MEM_POOL_SIZE 1024*1024
- /*used if SH_MEM is defined*/
--#define SHM_MEM_SIZE 32
-+#define SHM_MEM_SIZE 8
- #define TIMER_TICK 1
diff --git a/openwrt/package/ser/ser.control b/openwrt/package/ser/ser.control
deleted file mode 100644 (file)
index 303bc05..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-Package: ser
-Priority: optional
-Section: net
-Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
-Source: buildroot internal
-Description: SIP Express Router
- SIP Express Router (ser) is a high-performance,
- configurable, free SIP server.