projects
/
openwrt
/
svn-archive
/
archive.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
5165d92
)
packages/libs/file: make sure to remove magic.mime before regenerating it (#4422)
author
Jo-Philipp Wich
<jow@openwrt.org>
Mon, 5 Jan 2009 08:48:55 +0000
(08:48 +0000)
committer
Jo-Philipp Wich
<jow@openwrt.org>
Mon, 5 Jan 2009 08:48:55 +0000
(08:48 +0000)
SVN-Revision: 13870
libs/file/Makefile
patch
|
blob
|
history
diff --git
a/libs/file/Makefile
b/libs/file/Makefile
index c82fb7395272f639320f9e0bd9f2567bf24ea4ff..1be259985e6cd993cb9909bf3309abe9c2a715ea 100644
(file)
--- a/
libs/file/Makefile
+++ b/
libs/file/Makefile
@@
-79,7
+79,7
@@
define Package/file/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_DIR) $(1)/usr/share/file
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/file $(1)/usr/bin
- (cd $(PKG_BUILD_DIR)/magic/Magdir; for file in `ls`; do cat $$$${file} >> magic.mime; done)
+ (cd $(PKG_BUILD_DIR)/magic/Magdir;
rm -f magic.mime;
for file in `ls`; do cat $$$${file} >> magic.mime; done)
$(INSTALL_DATA) $(PKG_BUILD_DIR)/magic/Magdir/magic.mime $(1)/usr/share/file/magic
endef